Page MenuHomePhabricator

Display of subtasks in graphs for large tree is unusable as it cuts off task names or task IDs
Open, LowestPublic

Description

Taking this task: https://phabricator.wikimedia.org/T46529 as an example, we see that the tree is displayed in a way that it is impossible to see which actual tasks are displayed - only "T7..." is displayed and even hover, usually displaying the task label, does not work there.

I think it would be better if it displayed the full task ID and title, even at the expense of enabling the scroll in the box (which is there anyway for a wide enough tree) or maybe displayed just the ID and enabled the hover display?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2017, 8:19 PM

I can confirm this for certain screen widths, however there is a "Search" button to exactly work around this issue.
@Smalyshev: If the "Search" button is not sufficient, could you explain why?

Aklapper renamed this task from Phabricator display of subtasks for large tree is unusable to Display of subtasks in graphs for large tree is unusable as it cuts off task names or task IDs.Aug 5 2017, 9:53 PM
Aklapper added subscribers: zhuyifei1999, TerraCodes, Paladox.
TerraCodes added a comment.EditedAug 6 2017, 8:00 AM

There is a CSS workaround in T172615#3503748 and JS one in T172615#3503752 if anyone is interested.

Might have something to do with screen size/zoom since I zoomed out to 100% (windows has me zoomed in to 150% by default) I could easily read the task names.

Should this be upstreamed?

Huh, missed that. Should the task be closed then since there's a fix/workaround for it?

TerraCodes closed this task as Resolved.Dec 11 2017, 9:54 AM
TerraCodes claimed this task.

per

I can confirm this for certain screen widths, however there is a "Search" button to exactly work around this issue.
@Smalyshev: If the "Search" button is not sufficient, could you explain why?

TerraCodes removed TerraCodes as the assignee of this task.Dec 11 2017, 9:54 AM
Aklapper changed the task status from Resolved to Declined.Dec 11 2017, 11:07 AM
Bugreporter reopened this task as Open.Feb 13 2018, 7:30 PM

Reopen.

  1. "Search" button can not search indirectly related tasks in a task graph
  2. Showing the full task name instead truncate it is more user friendly even if task graphs will have scroll bars
Aklapper closed this task as Declined.Feb 14 2018, 12:34 PM
Aklapper triaged this task as Lowest priority.

Reopen.

  1. "Search" button can not search indirectly related tasks in a task graph

And it won't as Phab won't display hundreds of tasks. Performance.

  1. Showing the full task name instead truncate it is more user friendly even if task graphs will have scroll bars

You can always zoom out in your browser.

Restoring previous task status to reflect reality.

Bugreporter added a comment.EditedFeb 14 2018, 3:04 PM

Reopen.

  1. "Search" button can not search indirectly related tasks in a task graph

And it won't as Phab won't display hundreds of tasks. Performance.

I'm not request to increase the size limit of task graph. This is said about if we can display a task graph within maximum size, it should not be truncated, or otherwise there should be a way to view it (which the search button can not).

  1. Showing the full task name instead truncate it is more user friendly even if task graphs will have scroll bars

You can always zoom out in your browser.

Some browsers do not have this features, especially mobile browser which we can not append JS and CSS either. Hide the task graph is also not the optimal way to fix the problem - thebest way is always show the full task name and show a scroll bar if necessary.

Note the task graph of T144272 is so wide that already have a scroll bar in some browsers, but the task names are still truncated.

Restoring previous task status to reflect reality.

Aklapper reopened this task as Open.Feb 14 2018, 4:40 PM
Aklapper edited projects, added Phabricator (Upstream); removed Phabricator.

Note the task graph of T144272 is so wide that already have a scroll bar in some browsers, but the task names are still truncated.

Thanks! That is a valid point, hence reopening this task.

Restricted Application added a project: Upstream. · View Herald TranscriptFeb 14 2018, 4:40 PM
greg added a subscriber: greg.Feb 14 2018, 4:42 PM

(That looks like it should be a project/tag, not a tracking task, right?)

@greg: That's what Phabricator upstream developers would likely tell us, yes.

Upstream changes with some impact here:

  • After 2019 Week 13, the actual graph (the colored line drawing) is hidden by default on devices with smaller screens (see also T210482).
  • Since 2019 Week 7, the Search menu has a Standalone Graph option which renders the graph on a standalone page. (This change has been deployed here already.)

Neither of these changes directly address the most specific recent issue here (the column collapsing down uselessly to "T..."), although they may reduce how frequently it is a problem.

greg removed a subscriber: greg.Mar 27 2019, 11:20 PM