Page MenuHomePhabricator

Special:ListUsers "subpage parameters" can't be overridden by the form
Closed, ResolvedPublic

Description

  1. Access https://meta.wikimedia.org/w/index.php?title=Special:ListUsers/sysop, for example
  2. See that Group is marked as "(all)", which shouldn't.
  3. Now select from the dropdown another user group to list
  4. Result: it does not work.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 25 2017, 8:47 PM
matmarex renamed this task from Special:ListUsers somewhat broken after being OOjs-UI'd to Special:ListUsers "subpage parameters" can't be overridden by the form.Jul 25 2017, 10:35 PM

Change 367834 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/core@master] Fix Special:ListUsers "subpage parameter" handling

https://gerrit.wikimedia.org/r/367834

While this was caused by rMW283ee7238b7f: Special:ListUsers: Use HTMLForm and OOUI, the issue is with the HTMLForm part, not the OOUI part. :)

Thanks for the bug report and sorry, we really should have caught this in testing. :(

@matmarex Thanks. Another issue I've found is that apparently redirected grouppage-x pages are shown as redlinks in that page as well. Please check https://hu.wikipedia.org/wiki/Speci%C3%A1lis:Szerkeszt%C5%91k_list%C3%A1ja/checkuser for example. The page https://hu.wikipedia.org/w/index.php?title=Wikip%C3%A9dia:IP-ellen%C5%91r%C3%B6k&redirect=no do exist, but it keeps being redlinked. Maybe part of another oojs issue? Thanks.

Prtksxna closed this task as Resolved.Jul 28 2017, 6:57 AM
Prtksxna assigned this task to matmarex.
Prtksxna removed a project: Patch-For-Review.

@MarcoAurelio I am not able to see any redlinks. Could you please add a screenshot, and possibly raise a separate task?

Change 367834 merged by jenkins-bot:
[mediawiki/core@master] Fix Special:ListUsers "subpage parameter" handling

https://gerrit.wikimedia.org/r/367834

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptAug 12 2017, 1:44 PM