Investigate why some widgets are not displayed in the search results for widgets to add to a dashboard
Open, LowPublic

Description

While active, visible and being able to edit it as well, apparently W897 cannot be added to my dashboard. Looking for it in the dropdowns by title or number does not retrieve any result. It was created some time ago. Any config change that made old panels suffer from this? Thanks.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 27 2017, 7:36 PM

@Aklapper I'm not sure. It seems to be happening only with "old" panels. If I create one now and try to search it in the search field it indeed appears.

Aklapper renamed this task from Investigate W897 to Investigate W897: Not displayed in the search results for widgets to add to a dashboard.Sep 13 2017, 2:52 PM
Aklapper triaged this task as Low priority.

I just ran into this today, I have a bunch of W5nn panels that show in https://phabricator.wikimedia.org/dashboard/panel/ but they won't show if I try to add them to a panel: not in the "fl" list on the right, not autocomplete if I try to type them in either as W5nn or by a word or string in the panel name. Relatedly "load more results" in that fl list shows me a new copy of the same results.

Aklapper renamed this task from Investigate W897: Not displayed in the search results for widgets to add to a dashboard to Investigate why some widgets are not displayed in the search results for widgets to add to a dashboard.Sun, Feb 18, 8:25 PM