Page MenuHomePhabricator

setup releases2001.codfw.wmnet
Closed, ResolvedPublic

Description

Now that releases1001.eqiad.wmnet has been created in T164030 and the releases role has moved there from bromine,
we want to create the equivalent in codfw, releases2001. It made sense to do it all at once and just adjust the rsync directions.

Rsync all the files between them, designate one of them as the "active" upload server in Hiera which makes it easy to switch. (like install_server etc)

A new cache::misc director for releases has been added in https://gerrit.wikimedia.org/r/#/c/368183/ , add eqiad and codfw backend to make the service active/active. This is part of T156937 ("Provide cross-dc redundancy (active-active or active-passive) to all important misc services"), also T88761


Site/Location: CODFW
Number of systems: 1
Service: releases
Networking Requirements: none
Processor Requirements: 2
Memory: 4 GB
Disks: 128 GB

(all matching releases1001)

Details

Related Gerrit Patches:

Event Timeline

Change 368319 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/dns@master] add releases2001.codfw.wmnet

https://gerrit.wikimedia.org/r/368319

Dzahn updated the task description. (Show Details)Jul 27 2017, 11:15 PM
Dzahn added a project: vm-requests.

Change 368319 merged by Dzahn:
[operations/dns@master] add releases2001.codfw.wmnet

https://gerrit.wikimedia.org/r/368319

releases2001.codfw.wmnet has address 10.192.16.174
releases2001.codfw.wmnet has IPv6 address 2620:0:860:102:10:192:16:174

Change 368334 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] install_server: add install2001 to DHCP, partman

https://gerrit.wikimedia.org/r/368334

Change 368334 merged by Dzahn:
[operations/puppet@production] install_server: add install2001 to DHCP, partman

https://gerrit.wikimedia.org/r/368334

Dzahn added a comment.Jul 28 2017, 1:34 AM
[!!] Install the GRUB boot loader on a hard disk ├┐             
            │                                                    │             
 ┌──────────│         Unable to install GRUB in /dev/sda         │ ────────┐   
 │          │ Executing 'grub-install /dev/sda' failed.          │         │   
 │          │                                                    │         │   
 │          │ This is a fatal error.                             │         │   
 │ Running "│                                                    │         │   
 │          │     <Go Back>                       <Continue>     │         │   
 └──────────│                                                    │ ────────┘   
            └────────────────────────────────────────────────────┘

Mentioned in SAL (#wikimedia-operations) [2017-07-28T19:40:15Z] <mutante> releases2001 - OS install worked this time, could not reproduce grub error, signing puppet cert, initial puppet run (T171917)

Change 368477 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] releases: add releases2001 to site, change rsync direction

https://gerrit.wikimedia.org/r/368477

Change 368477 merged by Dzahn:
[operations/puppet@production] releases: add releases2001 to site, change rsync direction

https://gerrit.wikimedia.org/r/368477

Dzahn closed this task as Resolved.Jul 28 2017, 11:02 PM

Change 368527 had a related patch set uploaded (by Dzahn; owner: Dzahn):
[operations/puppet@production] cache::misc: release: add codfw backend, make active-active

https://gerrit.wikimedia.org/r/368527

Change 368527 merged by Dzahn:
[operations/puppet@production] cache::misc: releases: add codfw backend, make active-active

https://gerrit.wikimedia.org/r/368527