Page MenuHomePhabricator

Enable WebM playback for ogv.js video player shim
Closed, ResolvedPublic

Description

The ogv.js media player shim used for Safari/IE/Edge supports WebM in current versions, but we haven't enabled it since a) the original deployment was Ogg-only and b) the Ogg Theora videos play back faster.

In the short term, we're having trouble migrating ffmpeg2theora for Ogg Theora generation to the latest version of the base OS for the scalers (T145742)... and in the long term we'll need to drop Ogg to support adaptive streaming, so was already planning to deprecate it.

To do:

  • use 'enableWebM: true' in options for OGVPlayer setup
  • add video/webm to supported list for ogv.js backend in MWEmbed & video.js setup

Event Timeline

brion created this task.Aug 3 2017, 8:02 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 3 2017, 8:02 PM
Paladox added a subscriber: Paladox.Aug 3 2017, 8:06 PM

Change 370854 had a related patch set uploaded (by Brion VIBBER; owner: Brion VIBBER):
[mediawiki/extensions/TimedMediaHandler@master] [WIP] Enable WebM playback via ogv.js

https://gerrit.wikimedia.org/r/370854

Change 370854 merged by jenkins-bot:
[mediawiki/extensions/TimedMediaHandler@master] Enable WebM playback via ogv.js

https://gerrit.wikimedia.org/r/370854

Change 373126 had a related patch set uploaded (by Brion VIBBER; owner: Brion VIBBER):
[mediawiki/extensions/TimedMediaHandler@wmf/1.30.0-wmf.14] Enable WebM playback via ogv.js

https://gerrit.wikimedia.org/r/373126

Change 373127 had a related patch set uploaded (by Brion VIBBER; owner: Brion VIBBER):
[mediawiki/extensions/TimedMediaHandler@wmf/1.30.0-wmf.15] Enable WebM playback via ogv.js

https://gerrit.wikimedia.org/r/373127

brion added a comment.Aug 22 2017, 9:32 PM

The WebM enabling is live on beta -- see for example https://simple.wikipedia.beta.wmflabs.org/wiki/File:Tears_of_Steel_in_4k_-_Official_Blender_Foundation_release.webm which now plays back the 360p-fitting WebM in Safari and IE.

Once confirmed live to the world can disable the generation.

Change 373126 merged by jenkins-bot:
[mediawiki/extensions/TimedMediaHandler@wmf/1.30.0-wmf.14] Enable WebM playback via ogv.js

https://gerrit.wikimedia.org/r/373126

Change 373127 merged by jenkins-bot:
[mediawiki/extensions/TimedMediaHandler@wmf/1.30.0-wmf.15] Enable WebM playback via ogv.js

https://gerrit.wikimedia.org/r/373127

brion closed this task as Resolved.Aug 23 2017, 7:30 PM

Seems to be working. :)

Mentioned in SAL (#wikimedia-operations) [2017-08-23T19:36:20Z] <thcipriani@tin> Synchronized php-1.30.0-wmf.15/extensions/TimedMediaHandler: [[gerrit:373127|Enable WebM playback via ogv.js]] T172444 (duration: 00m 50s)