Page MenuHomePhabricator

Error in Module.Citation/CS1 in WikiMin
Closed, DeclinedPublic

Description

Hello all,

I copied and updated the modul Citation from idwiki (it works in there) but doesn't work in Wiki Min.
https://min.wikipedia.org/wiki/Templat:Cite_web
It's because the cite book and cite news template don't works in visual editor.

Event Timeline

Beeyan created this task.Aug 4 2017, 2:26 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 4 2017, 2:26 PM
Beeyan added a comment.Aug 4 2017, 2:27 PM

The error:

Lua error in Modul:Citation/CS1 at line 3366: data for mw.loadData contains unsupported data type 'function'.
Backtrace:
[C]: in function "error"
mw.lua:776: in function "loadData"
Modul:Citation/CS1:3366: in function "chunk"
mw.lua:511: ?

Hi @Beeyan.
As there are no steps to reproduce the problem (please see https://mediawiki.org/wiki/How_to_report_a_bug ):
Could you please add ?safemode=1 to the end of the URL on Wikimedia wikis to disable your personal CSS and JavaScript? Example: https://en.wikipedia.org/wiki/Literature?safemode=1 or https://en.wikipedia.org/w/index.php?title=Literature&action=edit&safemode=1. This allows you to test if a problem is because of your user scripts or personal gadgets without uninstalling them.

If this does not solve the problem, please use your web browser's developer tools. After opening them, please append ?debug=true to the address of the page on which you see the problem, if the address does not already include a ?. (If the address already includes a ?, append &debug=true instead - see https://www.mediawiki.org/wiki/ResourceLoader/Developing_with_ResourceLoader#Toggle_debug_mode for more information).
If there is a problem or an error with JavaScript it should be printed in the 'console' of the developer tools. Often JavaScript errors are a reason for problems, or a non-existing file called from another file (which can be seen in the 'network' tab).
For more information please see:

Beeyan added a comment.Aug 4 2017, 2:34 PM

Thanks Akklaper,

I do your suggestion but it's still same. I ask another Wikipedian and still same.

Please provide steps that allow others to see the problem.

Beeyan added a comment.Aug 4 2017, 6:07 PM
  • I change Min Wiki's Cite book template and copied the data from ID Wiki (ID WIki using the Module:Citation)
  • I copied all Module:Citation because Min Wiki doesn't have that module and tried to build from scratch by copying (CS1, etc like in this page)
  • Script error: Lua error in Modul:Citation/CS1 at line 536: Argument map not defined for this variable.
  • Details script error

Lua error in Modul:Citation/CS1 at line 536: Argument map not defined for this variable.
Backtrace:
[C]: in function "error"
Modul:Citation/CS1:536: ?
Modul:Citation/CS1:2127: ?
(tail call): ?
mw.lua:511: ?

  • I've revert my contribution and back to the original one in Cite book and Cite web.

Which steps do I have to follow to see the script error myself?

Aklapper changed the task status from Open to Stalled.Aug 8 2017, 10:42 AM
Aklapper closed this task as Declined.Aug 11 2017, 2:47 PM

Unfortunately closing this report as no further information has been provided.
@Beeyan: After you have provided the information asked for and if this still happens, please set the status of this report back to "Open" via the Add Action...Change Status dropdown. Thanks!