Page MenuHomePhabricator

Log entries use bad grammar
Closed, ResolvedPublic

Description

Author: mike.lifeguard+bugs

Description:
Your IP address has been blocked on all wikis by Dungodung (meta.wikimedia.org). The reason given was "testing (with permission)". The block's expiry is expires 20:30, 21 August 2008.

The language here is wrong - the string for the expiry either needs to be a time (ie indef, 2 weeks... instead of when it expires) or the log entry text needs to be changed such that an expiry time/date makes grammatical sense.


Version: unspecified
Severity: enhancement
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=23343

Details

Reference
bz15259

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 21 2014, 10:19 PM
bzimport added projects: GlobalBlocking, I18n.
bzimport set Reference to bz15259.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Aug 21 2008, 8:29 PM
demon added a comment.Aug 21 2008, 8:34 PM

Fixed in r39787. Param $4 is Block::formatExpiry(), which automatically adds "expires 2008....). Message should now read "The block expires ....."

Revision marked as fixme.

sumanah wrote:

Mike.lifeguard, is this grammar error still reproducible? Thanks.

(In reply to comment #3)

Mike.lifeguard, is this grammar error still reproducible? Thanks.

Of course not, it was replaced with another grammar error by the "fix", as noted in comment 2. :)
According to [[translatewiki:MediaWiki:Globalblocking-blocked/qqq]], error is still there.

(In reply to Nemo from comment #4)

(In reply to comment #3)

Mike.lifeguard, is this grammar error still reproducible? Thanks.

Of course not, it was replaced with another grammar error by the "fix", as
noted in comment 2. :)
According to [[translatewiki:MediaWiki:Globalblocking-blocked/qqq]], error
is still there.

Hasn't this been fixed? [[translatewiki:MediaWiki:Globalblocking-ipblocked/en]]

demon removed a subscriber: demon.Aug 19 2015, 4:41 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 19 2015, 4:41 PM
Liuxinyu970226 added a subscriber: Liuxinyu970226.
jrbs added a subscriber: jrbs.

Grammar is not about tone.

Looking at https://translatewiki.net/wiki/MediaWiki:Globalblocking-ipblocked/en this no longer seems to be a problem. Can this task be closed?

Nemo_bis closed this task as Resolved.Oct 11 2016, 7:33 AM

Yes: https://translatewiki.net/w/i.php?title=Special:Translate&group=ext-globalblocking&language=qqq&filter=&action=translate shows the error messages have been switched to the "Expiration: ..." format and the log https://meta.wikimedia.org/w/index.php?title=Special%3ALog&type=gblblock&uselang=en is now in the format "23:04, 10 October 2016 Vituzzu (talk | contribs) globally blocked User:80.116.11.236 (expiration 04:04, 12 October 2016) (Cross-wiki spam)".