Page MenuHomePhabricator

[wmf.12] Namespace exclusion not saved
Closed, ResolvedPublic

Description

When you save filters with Namespace Excluded and navigate away from RC page, and then return to RC - loading saved filters with excluded Namespaces will display results that

  1. Enter recentchanges
  2. Choose namespace(s) to filter
  3. Click exclude button
  4. It should exclude selected namespaces - it works
  5. Now save whole set.
  6. Close the RC page tab. Then navigate to RC page again.
  7. Load saved filter
  8. Notice selected namespaces are not excluded but included. Can't see "not" word on buttons in Active filters and on results it shows only from selected namespaces instead "from all excluding selected".

Details

Related Gerrit Patches:

Event Timeline

Wargo created this task.Aug 6 2017, 11:27 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 6 2017, 11:27 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript

@Wargo, thanks for this report. But I just saved not:talk and not:user talk filters on en.wikipedia, and it looks like it works fine. Can you please be more specific about what you're doing, and what doesn't work?

Wargo added a comment.Aug 7 2017, 4:05 PM

And when you enter on Recentchanges page and load saved setting you still have "not" options to them? It saves only namespaces but "not" is not assigned.

@Wargo: In general, a list of steps to reproduce is welcome (including URLs) to avoid misunderstandings and allow reproducing. Thanks :)

Wargo added a comment.Aug 7 2017, 4:50 PM
  1. Enter recentchanges
  2. Choose namespace(s) to filter
  3. Click exclude button
  4. It should exclude selected namespaces - it works
  5. Now save whole set
  6. Enter to RC again
  7. Load saved filter
  8. Notice selected namespaces are not excluded but included. Can't see "not" word on buttons in Active filters and on results it shows only from selected namespaces instead "from all excluding selected".

Maybe only me?

Etonkovidova renamed this task from Namespace exclusion not saved to [wmf.12] Namespace exclusion not saved.EditedAug 7 2017, 5:32 PM
Etonkovidova updated the task description. (Show Details)
Etonkovidova added a subscriber: Etonkovidova.

Thx, @Wargo - Confirmed on enwiki (wmf.12) and betalabs.

Ahh. Thanks Wargo. I see it now. The missing piece was that you have to leave RC page and then come back to it.

Change 370526 had a related patch set uploaded (by Sbisson; owner: Sbisson):
[mediawiki/core@master] RCFilters: preserve invert parameter in saved queries

https://gerrit.wikimedia.org/r/370526

Change 370526 merged by jenkins-bot:
[mediawiki/core@master] RCFilters: preserve invert parameter in saved queries

https://gerrit.wikimedia.org/r/370526

Etonkovidova added a comment.EditedAug 23 2017, 6:51 PM

Checked the fix in betalabs and in testwiki (wmf.15).

Etonkovidova closed this task as Resolved.Aug 23 2017, 8:29 PM