Page MenuHomePhabricator

-1 active users in Special:Statistics
Closed, DuplicatePublic

Description

Not sure if this is a known error but I couldn't find it reported.
Version: 1.28.2 & 1.29

Not sure how to reproduce, but when a wiki has no active users, Special:Statistics lists "-1" active users, same thing for 1 active user.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 8 2017, 9:15 AM
Zppix closed this task as Invalid.Aug 14 2017, 3:50 PM
Zppix added a subscriber: Zppix.

Fixed via using refresh specialpages script. (closing as invalid as requested by task author in IRC)

Reception123 reopened this task as Open.Dec 9 2017, 8:44 AM

The issue is back. (Version 1.29.2)

Seb35 added a subscriber: Seb35.Jan 13 2018, 5:36 PM

-1 is the default value for the statistic of active users. Do you have sensible values for others statistics (number of edits, of users, etc)? Do you have something in the table "site_stats"? Between the first and the second time you experienced the issue, what happened? (update, is it another site, etc.)

Note that the statistics of active users is computed differently than the special page ActiveUsers, and the statistics of active users can only updated through two means: run php maintenance/updateSpecialPages.php or run php maintenance/initSiteStats --update --active.

Also see T190485. Slightly different bug, but same underlying cause. Krinkle says there a bug somewhere about the actual issue with the installer, but I haven't found it yet.