Page MenuHomePhabricator

CodeMirror is incompatible with new wikitext editor
Closed, ResolvedPublic

Description

Reproduceable on testwiki: enabling both beta features and trying to edit page source results in Uncaught TypeError: Cannot read property 'urlProtocols' of null. That corresponds to urlProtocols = new RegExp( mwConfig.urlProtocols, 'i' ), in resources/mode/mediawiki/mediawiki.js. Attempts to quickly fix the issue with https://gerrit.wikimedia.org/r/#/c/370950/ and https://gerrit.wikimedia.org/r/#/c/370954/ didn't work. There is clearly some module dependency issue, but we were not able to identify it during our deployment window.

Event Timeline

MaxSem created this task.Aug 9 2017, 10:09 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 9 2017, 10:09 PM
MaxSem triaged this task as Unbreak Now! priority.Aug 9 2017, 10:09 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptAug 9 2017, 10:09 PM
Tgr added a subscriber: Tgr.Aug 11 2017, 1:11 PM

Opening the edit URL works, it's just the VE in-place loading thing that fails.

DannyH added a subscriber: DannyH.Aug 11 2017, 7:17 PM

Is it possible to detach the regular editor and the new wikitext editor versions? It's really frustrating to leave folks waiting on the regular editor version, because that's what folks were asking for in the proposal. I want to keep working on the new editor version too, but I'd like to get people using this.

Change 371580 had a related patch set uploaded (by MaxSem; owner: MaxSem):
[mediawiki/extensions/CodeMirror@master] Disable VE integration while we're fixing it

https://gerrit.wikimedia.org/r/371580

Change 371724 had a related patch set uploaded (by Esanders; owner: Esanders):
[mediawiki/extensions/CodeMirror@master] Separate out CodeMirror config data and add to VE mode

https://gerrit.wikimedia.org/r/371724

Change 371580 abandoned by Esanders:
Disable VE integration while we're fixing it

Reason:
See I2d7969782ee9f02347f7aa0c7f0eebb2d592904d

https://gerrit.wikimedia.org/r/371580

Change 371724 merged by jenkins-bot:
[mediawiki/extensions/CodeMirror@master] Separate out CodeMirror config data and add to VE mode

https://gerrit.wikimedia.org/r/371724

Found another teeny bug while testing this - NWE shows the 'Syntax Highlighting' tab in the dropdown and lets you enable it even if the user has not explicitly enabled the Beta feature. I'm not sure if this is intentional.

greg added a subscriber: greg.Aug 22 2017, 5:44 PM

This has been UBN! since Aug 9th, any updates?

MaxSem assigned this task to edsu.Aug 22 2017, 6:16 PM
MaxSem closed this task as Resolved.

Duh.

MaxSem reassigned this task from edsu to Esanders.Aug 22 2017, 6:17 PM
MaxSem added a subscriber: edsu.
DannyH moved this task from Untriaged to Archive on the Community-Tech board.Aug 31 2017, 12:34 AM