Page MenuHomePhabricator

Do not override edits by other users
Closed, DeclinedPublic

Description

If iabot has done some kind of editing, but an user has overridden the edit, most likely with a revert, then do not try to redo the edit.

Check if a previous edit has been done, and later been partial or fully removed, and if so do not redo the same edit.

Event Timeline

jeblad created this task.Aug 10 2017, 1:28 PM
Restricted Application assigned this task to Cyberpower678. · View Herald TranscriptAug 10 2017, 1:28 PM
jeblad renamed this task from Do not override users edits to Do not override edits by othrer users.Aug 10 2017, 1:29 PM
Cyberpower678 closed this task as Declined.Aug 10 2017, 1:39 PM

Cost of implementation is too high.

Closing as technically infeasible. IABot has opt-out methods in place to prevent edit warring. Please refer to the FAQ.

jeblad renamed this task from Do not override edits by othrer users to Do not override edits by other users.EditedAug 10 2017, 1:43 PM

I don't think you will be granted rights on nowiki to run this bot unless this is fixed.

I will post your comment on nowiki, and it should be up to the community to decide.

It already has rights to run on that wiki. You're not even providing any diffs.

jeblad added a comment.EditedAug 10 2017, 2:06 PM

Some additional info

Note that I am not the one blocking this bot, and that I can not do anything about the blockage.

Some additional info

Note that I am _not_ the one blocking this bot, and that I can _not_ do anything about the blockage.

Another trigger-happy admin apparently. I was not informed of a block, and the bot has a run page. If anyone ever bothers to read the instructions to shut off the bot.

I can hardly understand any of that, and no one is bothering to inform me of any issues, and are instead just blocking the bot. I cannot fix anything if I'm not aware of problems. And rather having the bot pick up when it gets reverted and to not repeat the edit, it's better to know why the edits are being reverted, and to fix the root cause. I need diffs for that, examples, something to investigate.

I did, the sentences aren't cohesive, so it's not really helpful.

So try Bing or Yandex.

So try Bing or Yandex.

I forgot those even existed.

So Bing is useless.

Yandex seems to work. The first linked thread, is already resolved.