Page MenuHomePhabricator

Content Translation in IE - UI problems
Closed, ResolvedPublic

Description

There are several UI issues.

  • The icons are too small (both IE10 and IE11)


  • Extra x is displayed (both IE10 and IE11)


This x is working and might be desired, unlike x on T187049.

  • Refresh button too big - IE11


This one is probably present on IE10 as well, but Suggestions don't work on IE10.

  • List item actions overflowing - IE10


Works good in IE11.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 10 2017, 11:21 PM
Etonkovidova updated the task description. (Show Details)Aug 28 2017, 9:11 PM
Arrbee triaged this task as High priority.Oct 27 2017, 6:16 AM

Solving UI problems should wait for major UI change that is about to happen with big patch for customization of personal header - T160918.
Inspecting what is wrong on IE might (likely) uncover more problems beyond mere UI problems. In my previous brief testing of CX on older browsers, I have noticed some OOjs widgets aren't working and the problem is broader than just IE.

Most of these are related to sizing of SVG images in IE, e.g. https://stackoverflow.com/questions/21840551/background-size-with-svg-squished-in-ie9-10 and https://thatemil.com/blog/2015/03/15/sizing-svg-background-images-in-internet-explorer/

The first issue is not actually UI issue. Same thing happens when trying to start a new translation: jQuery.Deferred Exception: Object doesn't support property or method 'values' (TypeError) in mw.cx.getDefaultTargetNamespace. https://stackoverflow.com/questions/42830257/alternative-version-for-object-values

Latter one could and should be fixed separately.

Etonkovidova updated the task description. (Show Details)Jan 13 2018, 1:25 AM
Etonkovidova updated the task description. (Show Details)

I've updated task to reflect recent UI adjustments - some of the previous issues got self-fixed due to modifications in UI.

I have updated the ticket with most recent UI related discoveries. More problems are added.
Each problem will (probably) be tackled separately and is marked with . When completed, piece of work will be marked with .

Two new tickets are created, as problems are separate from UI problems on Content Translation - T187049 and T187056.

The first issue is not actually UI issue. Same thing happens when trying to start a new translation: jQuery.Deferred Exception: Object doesn't support property or method 'values' (TypeError) in mw.cx.getDefaultTargetNamespace. https://stackoverflow.com/questions/42830257/alternative-version-for-object-values

Latter one could and should be fixed separately.

Yes, because of that I have created separate ticket T187056, where another JS related problem is described.

Solving UI problems should wait for major UI change that is about to happen with big patch for customization of personal header - T160918.

Custom header has one small problem on IE10, which is in the description of this ticket. Works nicely on IE11. Since translation view is inaccessible, header behavior cannot be tested over there.

Inspecting what is wrong on IE might (likely) uncover more problems beyond mere UI problems. In my previous brief testing of CX on older browsers, I have noticed some OOjs widgets aren't working and the problem is broader than just IE.

Two major problems are inability to start translation and suggestions not working on IE10. The thing I spoke before seems to be gone. Previously, searching for page in "New translation" dialog wasn't working in IE and newer browsers (some Operas 2-3 years old), but now problem seems resolved (probably in OOUI, haven't checked).

Once translation view is accessible again, more issues are likely to be uncovered.
Petar.petkovic moved this task from Backlog to In Progress on the Language-2018-Jan-Mar board.
Petar.petkovic moved this task from Backlog to In progress on the User-Petar.petkovic board.

Change 410191 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix list item action buttons on IE10

https://gerrit.wikimedia.org/r/410191

Change 410207 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix refresh button height on IE10/11

https://gerrit.wikimedia.org/r/410207

Change 410220 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix small icons on IE10/11

https://gerrit.wikimedia.org/r/410220

Section in description titled as "Extra x is displayed" should be considered as useful feature. Yes, there are two X, but those two serve different purposes. Smaller x clears the input, which works as expected, unlike T187049. Bigger X closes the dialog, which is completely different use case.

Also, in IE10/11 other pieces of our software show "clear button", like on Log in page:


Patch to remove the smaller x is submitted. @Pginer-WMF, should we proceed and remove it? (Change only affects IE10/11 and Edge 12+)

Petar.petkovic moved this task from In Progress to In Review on the Language-2018-Jan-Mar board.
Petar.petkovic moved this task from In progress to For Review on the User-Petar.petkovic board.
santhosh updated the task description. (Show Details)Feb 14 2018, 6:29 AM
Arrbee updated the task description. (Show Details)Feb 14 2018, 7:37 AM
Arrbee updated the task description. (Show Details)

Patch to remove the smaller x is submitted. @Pginer-WMF, should we proceed and remove it? (Change only affects IE10/11 and Edge 12+)

Yes, it makes sense to remove it. The element to select an article should work as a whole and the small x is surfacing functionality from the individual components that can create more confusion than help. Even if the symbol used were not an "x", it would be forcing an user to make a decision on which is the right way to undo their selection. One option keeps the process simpler.

Change 410220 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix small icons on IE10/11

https://gerrit.wikimedia.org/r/410220

Arrbee updated the task description. (Show Details)Feb 14 2018, 7:47 AM
Arrbee updated the task description. (Show Details)Feb 14 2018, 7:49 AM
Arrbee updated the task description. (Show Details)
Arrbee updated the task description. (Show Details)Feb 14 2018, 7:54 AM
Arrbee added a subscriber: Arrbee.

Additional issue:

Personal menu icon and indicator displaced when clicked - IE10 - to be tracked via T187243: DropdownWidget problems on IE10

Change 410207 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix refresh button height on IE10/11

https://gerrit.wikimedia.org/r/410207

Change 410191 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix list item action buttons on IE10

https://gerrit.wikimedia.org/r/410191

Etonkovidova closed this task as Resolved.Feb 16 2018, 11:15 PM

Checked all issues in SauceLabs - all fixes are in place. The double 'x' issue is tracked in T187594.