Page MenuHomePhabricator

Tool "wikiviz" loads assets from google, cloudflare, and bootstrapcdn, mixed http/https
Open, Needs TriagePublic

Description

https://tools.wmflabs.org/wikiviz/: https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js
https://tools.wmflabs.org/wikiviz/: https://netdna.bootstrapcdn.com/bootstrap/3.0.3/js/bootstrap.min.js
https://tools.wmflabs.org/wikiviz/: https://fonts.googleapis.com/css?family=Open+Sans:400,300,500,600,700
https://tools.wmflabs.org/wikiviz/: https://fonts.googleapis.com/css?family=Source+Sans+Pro:100,200,300,400,700,900
https://tools.wmflabs.org/wikiviz/: http://fonts.googleapis.com/css?family=Roboto+Slab:400,700,300,100
https://tools.wmflabs.org/wikiviz/: http://fonts.googleapis.com/css?family=Roboto+Mono:300,400,100,500,700
https://tools.wmflabs.org/wikiviz/: https://maxcdn.bootstrapcdn.com/bootstrap/3.3.5/css/bootstrap.min.css
https://tools.wmflabs.org/wikiviz/: https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/css/font-awesome.min.css
https://tools.wmflabs.org/wikiviz/: https://cdnjs.cloudflare.com/ajax/libs/moment.js/2.10.3/moment.min.js
https://tools.wmflabs.org/wikiviz/: https://cdnjs.cloudflare.com/ajax/libs/lodash.js/3.9.3/lodash.min.js
https://tools.wmflabs.org/wikiviz/: https://fonts.gstatic.com/s/sourcesanspro/v10/ODelI1aHBYDBqgeIAH2zlNzbP97U9sKh0jjxbPbfOKg.ttf
https://tools.wmflabs.org/wikiviz/: https://fonts.gstatic.com/s/sourcesanspro/v10/toadOcfmlt9b38dHJxOBGLsbIrGiHa6JIepkyt5c0A0.ttf
https://tools.wmflabs.org/wikiviz/: http://fonts.gstatic.com/s/robotoslab/v6/dazS1PrQQuCxC3iOAJFEJZ_TkvowlIOtbR7ePgFOpF4.ttf
https://tools.wmflabs.org/wikiviz/: https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.3.0/fonts/fontawesome-webfont.woff2?v=4.3.0
https://tools.wmflabs.org/wikiviz/: http://fonts.gstatic.com/s/robotoslab/v6/y7lebkjgREBJK96VQi37Zp0EAVxt0G0biEntp43Qt6E.ttf

Loading from external providers are discouraged. Please see parent tasks and J65.
In your case a direct replacement would be:

Event Timeline

Aklapper added a subscriber: dhvanil.

Resetting task assignee as that user account is not active anymore.

According to https://tools.wmflabs.org/admin/tool/wikiviz they are the only maintainer - maybe the tool should be disabled? @bd808?

According to https://tools.wmflabs.org/admin/tool/wikiviz they are the only maintainer - maybe the tool should be disabled? @bd808?

The tool seems to be down now without me having disabled it. The $HOME/service.manifest states that it should be running as a nodejs tool on the grid engine. There is source code in the $HOME including a LICENSE file declaring the code to be GPL v2+. The code is cloned from a non-public BitBucket repo.

If the solo maintainer is gone, we can transfer the tool to "Owner of abandoned tools" and archive the data in case anyone ever wants to revive it.