Clicking hyperlink and cite buttons twice breaks the editor
Closed, ResolvedPublic1 Story Points

Description

(Tested in Firefox 54 and Chrome 60)

Steps to reproduce:

  • Open Draft:Sandbox with the visual editor.
  • (optional) Select something
  • Click either the hyperlink or the cite button -> a popup balloon appears
  • Click either the hyperlink or the cite button (doesn't need to be same one)

Result:

  • The top border of the popup balloon is visible.
  • The editor is stuck and unusable, new changes are ignored by the save button (may be related to T159224)
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2017, 8:18 AM

As a workaround on the desktop, you can hit the Escape key to return to a usable state. But yes, this should be fixed.

Cirdan added a subscriber: Cirdan.Aug 16 2017, 4:16 AM
DLynch added a subscriber: DLynch.Aug 22 2017, 3:30 PM

I can only reproduce this on the live wikipedia. It doesn't happen locally or on beta. As such... I'd say either some gadget interaction, or it's going to go away when the next release deploy happens.

Deskana triaged this task as High priority.Aug 22 2017, 7:28 PM
Deskana added a subscriber: Deskana.

This is a very bad bug... but as @DLynch said, I can't seem to reproduce it anywhere. I'll do some more investigation.

Deskana changed the task status from Open to Stalled.Aug 22 2017, 7:29 PM

I can confirm that it works on https://simple.wikipedia.beta.wmflabs.org
Should this be marked as invalid or resolved?

Esanders changed the task status from Stalled to Open.Aug 23 2017, 2:33 PM
Esanders added a subscriber: Esanders.

I can reproduce locally and on various live wikis

I can confirm that it works on https://simple.wikipedia.beta.wmflabs.org
Should this be marked as invalid or resolved?

Let's wait until the production Wikipedias are using the latest software. I don't like closing tasks as resolved unless I'm pretty sure it's fixed, or as invalid unless I'm pretty sure the issue is not occurring any more, and neither of those are true yet. :-)

Change 373304 had a related patch set uploaded (by Esanders; owner: Esanders):
[VisualEditor/VisualEditor@master] Don't try to close context while opening

https://gerrit.wikimedia.org/r/373304

Change 373304 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] Don't try to close context while opening

https://gerrit.wikimedia.org/r/373304

Looks like this is only broken when using jQuery 2

Change 373166 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (d7bb71b95)

https://gerrit.wikimedia.org/r/373166

If https://gerrit.wikimedia.org/r/373304 fixes the issue, then please schedule it for SWAT deployment. We shouldn't wait nearly a full week for this change to roll out.

Change 373166 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (d7bb71b95)

https://gerrit.wikimedia.org/r/373166

Deskana closed this task as Resolved.Aug 24 2017, 8:01 PM
Deskana assigned this task to Esanders.
Deskana set the point value for this task to 1.

@Esanders Can you make sure this gets SWAT deployed? Thanks. :-)

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 24 2017, 8:01 PM