Page MenuHomePhabricator

Blank spaces in the 'Other review tools' box (MediaWiki:Recentchangestext box)
Closed, InvalidPublic

Description

As you can see on the picture, there are big blank and empty spaces while using New filters for edit preview. The problem is that this is not aesthetically and I have to scroll down unnecessarily. Please try to fix it.

A personal problem: MediaWiki:Recentchangestext is a very useful tool but since the latest update it doesn't appear as default. I've read about it on the gadget's talk page, so I get why it is collapsible, but I'd prefer if it was like the old. Its current positions is not optimal (as you can see on the first picture), it should be in the centre of the page as it was (or it's width should be as long as the page's).

Firefox:

Edge:

Event Timeline

Bencemac created this task.Aug 11 2017, 9:20 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 11 2017, 9:20 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
jmatazzoni assigned this task to Pginer-WMF.

Hi @Pginer-WMF, can you please have a look at this. I think the user is seeing that Saved Filters makes the box narrower, which causes line wraps.

A user on Nyorsk Wikipedia had a similar issue, exacerbated by a user there who included a (very nonstandard) vertical nav box.

Any ideas for making this better?

jmatazzoni renamed this task from Blank spaces and MediaWiki:Recentchangestext's position to Blank spaces in the 'Other review tools' box (MediaWiki:Recentchangestext box).Aug 22 2017, 7:17 PM
jmatazzoni added a comment.EditedAug 22 2017, 7:55 PM

Could we just go in and fix the HTML inside the box for these folks, so it doesn't wrap like that? Take out a couple of links? Maybe make the line spacing on wrap tighter>?

Hi @Pginer-WMF, can you please have a look at this. I think the user is seeing that Saved Filters makes the box narrower, which causes line wraps.

A user on Nyorsk Wikipedia had a similar issue, exacerbated by a user there who included a (very nonstandard) vertical nav box.

Any ideas for making this better?

This seems to be the issue we discussed in T166919#3485242

The proposed design was making use of the whole width for the expanded links, as illustrated below:

CollapsedExpanded

This comes at the price of taking additional vertical space when filters are expanded. However, someone interested in viewing the links may be more likely to accept that the content was pushed down than the links they are interested in are restricted.

Any ideas for making this better?

In addition to the issue with the community layout (...it should be in the centre of the page as it was (or it's width should be as long as the page's)..), the main issue with spacing seems to be a duplicate of T173265: Reduce vertical whitespace in the RC page with the New Filters

@Bencemac, please clarify. Is the white space you're not happy with the stuff underneath the "show last 50 changes" button in your screenshot? If so, then @Pginer-WMF is right, this is a duplicate of T173265, which is well on its way to being fixed.

@Pginer-WMF, I want to make sure I understand the solution you've suggested above: It looks like the "Other review tools" link and the Saved Filters are on the same line when the review tools box is closed; then, when it's opened, Saved Filters is pushed down on its own line. Is that correct? If so, it seems like a win-win and I think we should do it. Please confirm.

It looks like the "Other review tools" link and the Saved Filters are on the same line when the review tools box is closed; then, when it's opened, Saved Filters is pushed down on its own line. Is that correct?

Yes. That's correct.

@jmatazzoni Almost (because there is another below the "show new changes..." box).

The gap is less important on English WIkipedia than on Hungarian Wikipedia.

The gap is due to "Recent changes options" label and "Show new changes starting from 08:54, 25 August 2017". On hu.wp, there is also "Hide reviewed edits" which increases the gap.

Hungarian WikipediaEnglish Wikipedia

This gap doesn't exists on Beta wiki, because of LiveUpdates integration. Is it the expected solution?

This gap doesn't exists on Beta wiki, because of LiveUpdates integration. Is it the expected solution?

I think it is not because of "live updates" (T167743), but because of "view newest changes" (T163426) which according to the plan will be released as part of the "release group 2" before the filters move out of beta.

jmatazzoni closed this task as Invalid.EditedAug 30 2017, 9:24 PM

@Bencemac, thanks for your feedback. I'm closing this task as a duplicate. Both of your issues are being handled in other tasks.

Re. the vertical blank area, that is being closed up. If you want to see what the final layout will look in a few weeks, go to your Recent Changes page and append &liveupdate=1 at the end of the URL. E.g., here is the layout on English Wikipedia. As you can see, all the junk in your screenshot has been replaced by one link to "View newest changes." This replaces the old, confusingly labeled link to "Show new changes starting from 21:22, 30 August 2017"

Regarding your second issue, about the Recentchangestext box :

...it should be in the centre of the page as it was (or it's width should be as long as the page's).

I've opened and prioritized a task that I think will fix this problem nicely. Please see T174617.

Cheers!

@jmatazzoni Thank you very much! Just let me ask one question; I tested with &liveupdate=1 (see the picture). Is it alright or does the old version of MW cause it?

@jmatazzoni Thank you very much! Just let me ask one question; I tested with &liveupdate=1 (see the picture). Is it alright or does the old version of MW cause it?

The option to "hide reviewed edits" seems to be causing the additional space. This option seems to be a specific customisation of Hungarian Wikipedia that is probably not needed now that patrolled/unpatrolled filters are available. Other Wikipedias where patrolling filters are available such as Catalan do not seem to have such link.

So there may be two action items here:

  • Remove the "hide reviewed edits" link from Hungarian Wikipedia.
  • Adjust the spacing of the area of the old filters to improve on those cases where other wikis still add filters in the old way.

Thanks Pau. But, looing at @Bencemac's screenshot below, i don't understand why the line for "Recent changes options" is still there. On en.wiki, when you go to &liveupdate=1, this element is removed. See screenshot below. @Mooeypoo do we have to do something special to make that go away in Hungarian, or is that fix just rolling out in phases somehow.

Thanks Pau. But, looing at @Bencemac's screenshot below, i don't understand why the line for "Recent changes options" is still there.

My understanding is that the line gets removed when there are no options. In most cases there are no options since those have been migrated to the new system, but some wikis may have extensions/gadgets/etc. that add some options. This seems to be the case for Hungarian Wikipedia. What I found strange is that other wikis had also the patrolled/unpatrolled functionality which I assumed this would be related to.

The option to "hide reviewed edits" seems to be causing the additional space. This option seems to be a specific customisation of Hungarian Wikipedia that is probably not needed now that patrolled/unpatrolled filters are available.

It's not patrolled/unpatrolled. It's Flagged Revisions, also known as Pending Changes: T159791: Create new RC Filters group for 'Flagged Revisions', based on the old 'Hide reviewed edits' function

Thanks Pau. But, looing at @Bencemac's screenshot below, i don't understand why the line for "Recent changes options" is still there.

This will be removed by https://gerrit.wikimedia.org/r/#/c/373716/ (regardless of whether there are non-migrated filters).