Page MenuHomePhabricator

Choosing suggested item twice gives empty source title
Closed, ResolvedPublic

Description

There is a bug when user is on Suggestions list and chooses to translate one of suggested items, then clicks Cancel. Next opening of the same item gives empty field for source title.

Following two screenshots show suggested item opening first and second time.

To point user in the right direction, dialog directs user to enter target title after item is chosen. That makes great sense in the first opening, but when title gets lost on second opening, user may be clueless.
And if user needs to enter source article title again, this turns into what "New Translation" dialog is supposed to be doing.

Event Timeline

Restricted Application added subscribers: TerraCodes, Aklapper. · View Herald TranscriptAug 11 2017, 12:46 PM

Change 371467 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Fix dashboard usability issues

https://gerrit.wikimedia.org/r/371467

Petar.petkovic triaged this task as Normal priority.Aug 11 2017, 1:52 PM

Change 371467 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Fix dashboard usability issues

https://gerrit.wikimedia.org/r/371467

Checked in enwiki wmf.15 - the issue is not present anymore.

Etonkovidova closed this task as Resolved.Aug 28 2017, 10:29 PM