Page MenuHomePhabricator

Watchlist legend alignment is weird
Closed, ResolvedPublic

Description

The [[Special:Watchlist]] page shows a legend block. Alignment of items inside this block looks a little weird.


Event Timeline

Dereckson updated the task description. (Show Details)

Change 372084 had a related patch set uploaded (by Isarra; owner: Isarra):
[mediawiki/skins/Timeless@master] Fix messed up recent changes/watchlist legends

https://gerrit.wikimedia.org/r/372084

Change 372085 had a related patch set uploaded (by Dereckson; owner: Isarra):
[mediawiki/skins/Timeless@wmf/1.30.0-wmf.14] Fix messed up recent changes/watchlist legends

https://gerrit.wikimedia.org/r/372085

Change 372084 merged by jenkins-bot:
[mediawiki/skins/Timeless@master] Fix messed up recent changes/watchlist legends

https://gerrit.wikimedia.org/r/372084

Change 372086 had a related patch set uploaded (by Dereckson; owner: Isarra):
[mediawiki/skins/Timeless@wmf/1.30.0-wmf.13] Fix messed up recent changes/watchlist legends

https://gerrit.wikimedia.org/r/372086

Change 372086 merged by jenkins-bot:
[mediawiki/skins/Timeless@wmf/1.30.0-wmf.13] Fix messed up recent changes/watchlist legends

https://gerrit.wikimedia.org/r/372086

Change 372085 merged by jenkins-bot:
[mediawiki/skins/Timeless@wmf/1.30.0-wmf.14] Fix messed up recent changes/watchlist legends

https://gerrit.wikimedia.org/r/372085

Isarra closed this task as Resolved.Aug 15 2017, 11:21 PM
Isarra claimed this task.

Mentioned in SAL (#wikimedia-operations) [2017-08-15T23:55:07Z] <dereckson@tin> Synchronized php-1.30.0-wmf.13/skins/Timeless/resources/screen-common.less: Fix messed up recent changes/watchlist legends (T173151) (duration: 00m 54s)

Mentioned in SAL (#wikimedia-operations) [2017-08-15T23:58:45Z] <dereckson@tin> Synchronized php-1.30.0-wmf.14/skins/Timeless/resources/screen-common.less: Fix messed up recent changes/watchlist legends (T173151) (duration: 00m 50s)

Legoktm reopened this task as Open.Nov 24 2017, 9:06 AM

This is still not fixed on mediawiki.org :/

TheDJ added a comment.EditedNov 24 2017, 9:12 AM

This is caused by dt element sharing a style block with headers, which have: margin: 1.5em 0 0.5em. This makes their height larger than the line-height of single line dd elements following them.

If that margin was intentional, then it was probably supposed to be on the <dl> element instead. And maybe it's just a complete oversight :)

Anyway, dt's are not headers and should not be treated like such.

TheDJ triaged this task as High priority.Nov 24 2017, 9:13 AM
Izno added a comment.Nov 24 2017, 12:55 PM

Since @Legoktm merged my task here, I'd also like to note the abbreviations in the legend should also be in bold face.

Evad37 added a subscriber: Evad37.May 2 2018, 1:43 AM

Looks like this is a specificity issue (T192560): .mw-changeslist-legend dt has the rule margin: 0 0.5em 0 0, but this is overridden by #mw-content dt having rules margin-top: 1em; and margin: 1.5em 0 0.5em;

Isarra closed this task as Resolved.Apr 9 2019, 10:56 PM

Should now be properly resolved in https://gerrit.wikimedia.org/r/c/mediawiki/skins/Timeless/+/501850, which should go out next week.

(Forgot to tag this because I didn't realise this hadn't already been resolved, and thought I'd reintroduced it and then had to fix it again.)