Page MenuHomePhabricator

Archive "AdvancedMeta" extension
Closed, ResolvedPublic

Description

This extension was unmaintained for years and now no longer works on supported versions of MediaWiki (1.27+).

Event Timeline

Kghbln created this task.Aug 12 2017, 3:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 12 2017, 3:03 PM
MarcoAurelio added a subscriber: MarcoAurelio.

Change 371639 had a related patch set (by MarcoAurelio) published:
[mediawiki/extensions@master] Remove Extension:AdvancedMeta

https://gerrit.wikimedia.org/r/371639

Change 371640 had a related patch set (by MarcoAurelio) published:
[integration/config@master] Archive Extension:AdvancedMeta

https://gerrit.wikimedia.org/r/371640

Change 371641 had a related patch set (by MarcoAurelio) published:
[translatewiki@master] Archive Extension:AdvancedMeta

https://gerrit.wikimedia.org/r/371641

This comment was removed by MarcoAurelio.

@MarcoAurelio You provided good points in T173184#3521309. Originally I thought back in T160374 that this would be a good idea... and @Aklapper pointed out the same thing you did.

Looking back now, I realize my idea is dumb, and that adding Documentation and MediaWiki-extension-requests just bluffs up the task with unnecessary projects, and really should just be kept to the scope of Cleanup. I think I'll make a separate task to remove those projects from being auto-added.

Also to both you and @Kghbln:

If you join the Cleanup project, this lets you use Form33 (instead of having to copy paste), which is listed on:

Once you become a member, you'll be able to use that form! You can also add it to your favorites via https://phabricator.wikimedia.org/favorites/menu/configure/custom/ (although you probably already know that). Hope this helps! Sorry for the slight-off-topicness. Forgive me for not adding this in Cleanup's project description - I'll go add that now.

@Kghbln: I should've pointed this out earlier, but I didn't so that's my fault; You can simply remove any todo-items instead of checking them off if they're not applicable to the project (so e.g you can remove the Phabricator project tasks). I'll do that right now :)

Thanks guys for your work!

@SamanthaNguyen No problems wrt. projects. However with regards to https://phabricator.wikimedia.org/maniphest/task/edit/form/33/ it is not Cleanup the project that let you use it but MediaWiki-extension-requests. Not sure if that was intended or not. Regards and thanks for your kind words and help as well.

MarcoAurelio updated the task description. (Show Details)Aug 12 2017, 8:39 PM

Oh right - yeah it'd be better fit under Cleanup instead. I'll mention that in the new task too :)

Change 371641 merged by jenkins-bot:
[translatewiki@master] Archive Extension:AdvancedMeta

https://gerrit.wikimedia.org/r/371641

@SamanthaNguyen Thanks for your info. Admittedly I indeed just copy-pasted from an existing task. I just joined the respective group and set up my personal menu to show the form so I can directly use it in future. Just note that this form still adds Documentation, MediaWiki-extension-requests and Cleanup So if something should not be in there it still needs to be removed from the form itself.

Kghbln updated the task description. (Show Details)Aug 13 2017, 4:44 PM
MarcoAurelio updated the task description. (Show Details)Aug 13 2017, 6:54 PM

Change 371639 merged by Umherirrender:
[mediawiki/extensions@master] Remove Extension:AdvancedMeta

https://gerrit.wikimedia.org/r/371639

MarcoAurelio updated the task description. (Show Details)Aug 13 2017, 9:22 PM
Florian updated the task description. (Show Details)Aug 14 2017, 4:14 PM

Change 371640 merged by jenkins-bot:
[integration/config@master] Archive Extension:AdvancedMeta

https://gerrit.wikimedia.org/r/371640

SamanthaNguyen closed this task as Resolved.Aug 17 2017, 12:35 AM
SamanthaNguyen removed a project: Patch-For-Review.
SamanthaNguyen removed a subscriber: gerritbot.

\o/

Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptAug 17 2017, 9:18 AM

Yes, the project should've also be archived. Thanks. I've declined the remaining tasks as the extension is archived.