Page MenuHomePhabricator

[Task] Tag releases of smaller Wikibase libraries significantly lagging behind
Closed, ResolvedPublic

Description

Full list of Wikibase code libraries and when the most recent release happened, as of 2017-08-12:

Candidates for an urgent release in reverse chronological order:

Patch-For-Review:

See also:

Event Timeline

Restricted Application added subscribers: PokestarFan, Aklapper. · View Herald TranscriptAug 12 2017, 8:48 PM
thiemowmde updated the task description. (Show Details)Aug 12 2017, 9:04 PM
thiemowmde triaged this task as Lowest priority.Sep 6 2017, 3:28 PM
thiemowmde updated the task description. (Show Details)

Honestly, I think it's part of very bigger problem and it's large number of libraries that we have making it practically unmaintainable, I recently discovered a few more libraries, lots of time I don't have access to merge PRs because it's in another organization and I don't even know use case of most of them or for example, the difference between WikibaseDataModelJavaScript and DataValuesJavaScript. Cleaning them up, consolidating them into one organization (some are in wmde, some are in Wikidata, some are DataValues, some are in gerrit, some are in Wikidata-lib, etc.) and making a catalog of them to make onboarding and offboarding of developer easier, and maybe merging some of them are huge technical debts that will bite us in future.

I partly agree, but note that what you said is not covered by this ticket.

  • The most well maintained list of components is at http://wikiba.se/components/.
  • I believe that having lots of smaller libraries is not a problem in itself. The contrary. I believe it's a good thing to split independent clusters of code off into independent libraries. I wish we would do this much, much more often. One recent attempt can be seen at https://github.com/DataValues/Text. The problem is more that these components are scattered around on Gerrit and different GitHub organizations.
  • I want us to merge some of the libraries we maintain for a long time:
    • Some of the minor DataValues components should just be merged (excluding Geo, Number, Text, and Time).
    • ValueView should just be merged into the Wikibase View directory.

When writing subtasks of the kill the build ticket I drew the dependencies of all of our libs, see here attached:

This might help us visualize what is going on :)

Thanks for bringing this up @Ladsgroup. The thing that's been bugging me the most is that for more as a fairly new person it is not really clear which of all of those libs are something I should feel responsible for, and what. Having this information better included in on (and off-) boarding process is something that should definitely happen, IMO. I am mean both the more "administrative" part (give/revoke people all required permissions), but also the more "awareness" part, i.e. to make new folks aware and familiar what are the components, where they are, what for, etc.
The number of all those libs, and the fact of them being scatter around many places is clearly not making things easier. It could still be fine though, if the stuff was made clear IMO.

thiemowmde updated the task description. (Show Details)Sep 22 2017, 2:18 PM
Krinkle updated the task description. (Show Details)Oct 9 2017, 9:15 PM
thiemowmde updated the task description. (Show Details)Oct 24 2017, 3:29 PM
dbs added a subscriber: dbs.Jul 20 2018, 1:56 PM
thiemowmde closed this task as Resolved.Sep 4 2018, 11:44 AM
thiemowmde removed thiemowmde as the assignee of this task.
thiemowmde updated the task description. (Show Details)