Page MenuHomePhabricator

Special:AllPages no longer has the ability to "hide redirects", like Special:PrefixIndex (regression?)
Closed, InvalidPublic

Description

Special:AllPages no longer provides an option to "Hide redirects", like Special:PrefixIndex does. Furthermore, it does not respect the choice of "&hideredirects=1" when added "manually" to the page's URL.

Both pages used to be able to hide redirects, as a result of (presumably):

Note that Special:Statistics still links the "Content pages" label to a URL ending in "&hideredirects=1".

(All links here are to the English WIkipedia, but the behavior is seen on all of the random handful of Wikimedia wikis I checked.)

This looks like a regression. Or is it intentional for some reason?

Event Timeline

Dcljr created this task.Aug 17 2017, 12:45 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 17 2017, 12:45 AM
Reedy added a subscriber: Reedy.

Intentional.

Disabled in misermode, which is enabled on WMF wikis

https://github.com/wikimedia/mediawiki/blob/91a920f /includes/specials/SpecialAllPages.php#L73-L74

I added it months ago https://github.com/wikimedia/mediawiki/commit/454b199537b53bf1851afe8d38c9c0a817a6a310 for T160916

History/activity can be followed there

It's not considered (yet?) a performance problem in Prefix Index

Furthermore, it does not respect the choice of "&hideredirects=1" when added "manually" to the page's URL.

It wouldn't, because it's hard disabled in code. Things aren't just hidden from the UI

Reedy closed this task as Invalid.Aug 17 2017, 12:51 AM

It wouldn't, because it's hard disabled in code. Things aren't just hidden from the UI

Why "&hideredirects=1" is not removed from these URLs if it is useless there?

What are "these URLs"? Do you refer to links on Special:Statistics ? Something else?

Dcljr added a comment.Aug 18 2017, 4:06 AM

[If I may…] Yes, Obsuser was referring to the links coming from Special:Statistics.

Reedy added a comment.Aug 28 2017, 7:26 PM

It wouldn't, because it's hard disabled in code. Things aren't just hidden from the UI

Why "&hideredirects=1" is not removed from these URLs if it is useless there?

Because the code wasn't modified to do so. It could be done, it's a relatively small issue to fix. But do we really need to?

No, if when there is more important stuff – no.