Page MenuHomePhabricator

Artifact in displayed reference header in Wikidata
Closed, ResolvedPublic

Description

There is an artifact in the reference at the statements in Wikidata when there is no references. With my Danish settings it displays: "0$3+$2$4 referencer". A refresh of the browser clears it yield the proper format "0 referencer" (in Danish).

The artifact has just appeared perhaps less than an hour ago.

Event Timeline

Fnielsen created this task.Aug 17 2017, 9:42 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 17 2017, 9:42 PM

I noticed similar behaviour when adding a sitelink yesterday.
I can reproduce it very easy. Just click on edit next in a sitelink column and this is the result:


Or add a new statement to an exisiting property:

It also occurs when adding a complete new statement.

Change 373260 had a related patch set uploaded (by WMDE-leszek; owner: WMDE-leszek):
[mediawiki/extensions/Wikibase@master] Mass remove no longer used sitelink/reference counters from i18n messages

https://gerrit.wikimedia.org/r/373260

The fix takes some time to gets deployed in the mean time you can remove it in Mediawiki:wikibase-sitelinks-counter/da and Mediawiki:wikibase-statementview-references-counter/da (or your language code) by removing "{{PLURAL:$2|0=|$3+$2$4}}". See for example https://gerrit.wikimedia.org/r/#/c/373260/1/repo/i18n/af.json

It's es. I am not a Wikidata admin so I cannot edit those messages, and I prefer to wait for the fix to be deployed, when the patch above gets merged. It does not bother me as long as you were aware of the issue, which obviously you are :) Thanks.

I fixed them in translatewiki: https://translatewiki.net/w/i.php?title=Special:Contributions/Ladsgroup&dir=prev&offset=20170823114712&target=Ladsgroup

These changes gets overwritten by translatewiki bot if don't fix it there, so the only thing we can do right now is to wait.

Change 373260 abandoned by WMDE-leszek:
Mass remove no longer used sitelink/reference counters from i18n messages

Reason:
Fixed on translatewiki, thanks Ladsgroup!

https://gerrit.wikimedia.org/r/373260

Is there anything we still need to do here or can we close this?

We can close it, it's not deployed but it will be soon. If backport needed, let me know.

Zoranzoki21 added a subscriber: Zoranzoki21.

Super what is solved, because it was also strange for me to show it to me.

thiemowmde closed this task as Resolved.Aug 31 2017, 8:42 AM
thiemowmde assigned this task to Ladsgroup.
thiemowmde triaged this task as Normal priority.
Restricted Application added a project: User-Ladsgroup. · View Herald TranscriptAug 31 2017, 8:42 AM