Page MenuHomePhabricator

Petition can not be signed when transcluded, says user is blocked
Closed, ResolvedPublic

Description

When transcluded e.g. at https://wikimediafoundation.org/wiki/WPZeroPetition petitions always give the message "You cannot sign this petition because you are currently blocked." This occurs even when logged out.

It is still possible to view and sign at the Special page directly e.g. https://wikimediafoundation.org/wiki/Special:Petition/WPZero

No idea how long this has been broken. Looks like the last petition signature was 26 July, and the last signature on the WPZero petition was 21 February.

Event Timeline

Pcoombe created this task.Aug 18 2017, 5:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 18 2017, 5:00 PM

Oh, that might be my fault. I suspect this is a side effect of 7730dee63b1 (Transcluded special pages are now always treated as if they come from 127.0.0.1 to prevent data leaks, and be nicer to caching)

Sorry @Bawolff, I really haven't had time to look at this. Do you know if there's an easy way to fix this? It's not urgent since we aren't running the WP Zero petition any more (which was the only use of this).

Sorry @Bawolff, I really haven't had time to look at this. Do you know if there's an easy way to fix this? It's not urgent since we aren't running the WP Zero petition any more (which was the only use of this).

If its caused by what i think it is, overriding the method maxIncludeCacheTime() so it returns 0 would fix it.

Change 380560 had a related patch set uploaded (by Pcoombe; owner: Pcoombe):
[mediawiki/extensions/Petition@master] Do not cache Special:Petition when transcluded

https://gerrit.wikimedia.org/r/380560

Change 380560 merged by jenkins-bot:
[mediawiki/extensions/Petition@master] Do not cache Special:Petition when transcluded

https://gerrit.wikimedia.org/r/380560

Pcoombe closed this task as Resolved.Oct 2 2017, 3:07 PM