Page MenuHomePhabricator

Autocorrection of numbers needed for Urdu Wikipedia
Open, Needs TriagePublic

Description

Since Urdu Wikipedia currently uses English style numbers, the comma sign and decimal points should be displayed as it is in English when these come between two numerical digits. For this, autocorrection is needed. Detailed explanation with examples is available here: https://meta.wikimedia.org/wiki/User:Hindustanilanguage/Autocorrection_of_Numbers_for_UrWiki

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 18 2017, 7:59 PM

Do you know if such "autocorrection" exists for any other languages already (so this would be more or less about changing wiki configuration to "enable" this)?
Or is this a feature request to write completely new code for a functionality that does not exist at all yet?

I am not aware if such "autocorrection" exists for any other languages already. I request you to check if such a thing exists on any of the Perso-Arabic language Wikis and implement modified wiki configuration to "enable" this.

In case if it doesn't exist, I request you or any other technical expert to please write completely new code for a functionality that does not exist at all yet. Umpteen thanks in advance.

Aklapper closed this task as Declined.Aug 20 2017, 11:19 AM

If no such autocorrection already exists than I do not see convincing reasons to add such code to MediaWiki, as this totally sounds like bot territory to me instead.
Hence I'm going to be bold and decline this task as (as far as I know) we do not track requests to create a bot that does something here in Phabricator...

Have you considered writing a bot that periodically goes through pages and changes the numbers?
See https://en.wikipedia.org/wiki/Wikipedia:Bot_requests (though that is English Wikipedia.)

Dear friend, I've drafted this request after discussion with a WMF staff member.

I've also placed a request for Autocongratulatory messages on Urdu Wikipedia. Although this also involves creation / reconfiguration of a bot, a bug to this effect was filed by J D Forrester.

I anxiously look for your advice, support and valuable guidance in both the matters as my main aim to ultimately solve the problems on hand.
Thanks in advance.

Aklapper reopened this task as Open.Sep 4 2017, 5:06 PM

Although this also involves creation / reconfiguration of a bot, a bug to this effect was filed by J D Forrester.

Do you have a link to that bug report?

I anxiously look for your advice, support and valuable guidance in both the matters as my main aim to ultimately solve the problems on hand.

It is still unclear to me what exactly is requested in this task and whether this is about a software bug or a feature request.
If some things are shown completely wrong (for example 2.5 vs. 5_2 ) this seems like a valid bug report.
But hard to say without clear steps.
Please provide, in separate sections (see the Phabricator Help),

  1. clear steps to reproduce the problem,
  2. a clear description of what you get currently,
  3. a clear description of what you expect to see.

You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results.

Restricted Application added a project: I18n. · View Herald TranscriptSep 4 2017, 5:06 PM

This has the RTL tag, but is this actually an RTL issue?

Urdu is an RTL language, but this looks like an issue with using certain characters, and not an issue of incorrect RTL displaying. So I am removing the RTL tag, but if I'm wrong, please restore it.

For the issue itself, I also don't completely understand what is asked here, but my guess is that it can be resolved by writing a bot. If @hindustanilanguage can give clear examples of strings that should be replaced, then somebody who is experienced with writing bots, can create a bot that does it, and run it regularly.

Amire80 removed a project: RTL.Feb 3 2018, 12:15 PM

OK, now I read the example page and I see the RTL problem.

This is a problem that should be solved by a text replacement bot.

If this should be solved by a bot then the request might be out of scope for Phabricator as I am not aware of a general place to request bots.

Amire80 moved this task from Untriaged to RTL on the I18n board.Feb 26 2018, 10:38 AM