Page MenuHomePhabricator

Bug: Tracking Page Views wikipedia.de broken
Closed, ResolvedPublic1 Story Points

Description

there is a tracking pixel ("/wpde-page-imp") to measure wikipedia.de visits. see: https://github.com/wmde/fundraising/issues/1149

it seems data is not tracked anymore by piwik since 10th july. could you pleas please have a look?

PR is on GitHub: https://github.com/wmde/Wikipedia.de/pull/24. Although already reviewed, it has been sitting there for quite a while and needs a rebase before merging.

Acceptance Criteria:

  • Banners impressions on wikipedia.de are tracked with a chance of 1%.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 21 2017, 12:39 PM

@kai.nissen obviously nothing happened here (i also checked piwik). can you please pick that up? we need to track that data. thanks!

kai.nissen added a subscriber: MasinAlDujaili.EditedFeb 27 2018, 1:30 PM

Sorry, I missed this one. When creating a ticket, can you please make sure to use the tag WMDE-Fundraising-Tech instead? Please feel free to add me as a subscriber as well.

As I remember, the idea was to use the Piwik instance of WMDE for general page impressions on wikipedia.de.

@MasinAlDujaili Can you give us an update on this?

Please use my WMDE tagged account, MasinAlDujailiWMDE.

According to https://piwik2.wikimedia.de, everything's logged just fine.

Restricted Application added a project: WMDE-FUN-Team. · View Herald TranscriptFeb 27 2018, 2:14 PM

@kai.nissen a bit more of the background: indeed that data is beeing tracked via wmde piwik. but for two reasons we thought that would not be enough: 1. there are always short data blackouts on wmde piwik (which in fact again is the case in the time frame since july '17), 2. we want to cross check and validate the data of piwik wmde (because the issue is a such important one).

(willl use the tag in future issues)

kai.nissen updated the task description. (Show Details)Apr 10 2018, 12:40 PM
kai.nissen set the point value for this task to 1.
kai.nissen updated the task description. (Show Details)Apr 18 2018, 4:29 PM
kai.nissen removed a subscriber: MasinAlDujailiWMDE.
gabriel-wmde moved this task from Todo to Doing on the WMDE-FUN-Sprint-2018-04-18 board.

@Tobias_Schumann_WMDE : The current patch will log the impressions as the fake "page" wpde-page-imp in spenden.wikimedia.de. Wouldn't it be more convenient an in line with Piwik if we tracked them as an access to wikipedia.de? We already have wikipedia.de as a possible tracking target URL in our Piwik.

@gabriel-wmde: Ok, since that won't alter anything to the method and specifications of the tracking, let's do that.

gabriel-wmde removed gabriel-wmde as the assignee of this task.Apr 23 2018, 4:06 PM
gabriel-wmde moved this task from Doing to Deploy on the WMDE-FUN-Sprint-2018-04-18 board.
gabriel-wmde added a subscriber: gabriel-wmde.

Merged the PR, tested the tracking with a local copy. This can now be deployed

The people responsible for deployments during this and next week will only be able to do it after T193013 is finished. Do you want to carry this over to the next sprint or do an extraordinary deployment by the only person who can do deployments?

Works as expected, thank you!

kai.nissen moved this task from Done to Deploy on the WMDE-FUN-Sprint-2018-04-18 board.
kai.nissen closed this task as Resolved.May 28 2018, 1:31 PM