Page MenuHomePhabricator

Support translation of first page and title of training modules
Closed, ResolvedPublic

Description

New text:
There doesn't appear to be any way for users to translate the content of the landing page for training modules (e.g. https://outreachdashboard.wmflabs.org/training/editing-wikipedia/wikipedia-essentials) or the title.

Original text:
Hello,

In the Basque Wikipedia we are trying to translate the training modules for the programs and events dashboard. It's really difficult to find where this must be translated and once done (https://meta.wikimedia.org/wiki/Training_modules/wikipedia-essentials/eu) it doesn't show on the dashboard.

What is the correct way for translating this?

Thanks

Event Timeline

Theklan created this task.Aug 21 2017, 12:45 PM
Restricted Application added subscribers: Base, Aklapper. · View Herald TranscriptAug 21 2017, 12:45 PM

That training module hasn't been ported to Meta yet. I'm hoping to do that soon, after which it will be translatable.

Thanks @Ragesoss! I would need it this october, as it will be some work to translate everything. Could I help you with something?

Thanks @Ragesoss! I would need it this october, as it will be some work to translate everything. Could I help you with something?

Yes, if you want you could port slides into the wiki format. You can see a few examples — the ones that don't end in .json are the ones to emulate — here: https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides-test

Starting from here, we need the wiki versions of the rest of the slides from that wikipedia-essentials module: https://outreachdashboard.wmflabs.org/training/editing-wikipedia/wikipedia-essentials/notability-continued

I just added the first few redlinks. If you want to create those pages and continue with the rest of that module, that would be very helpful!

I will start with them... but still don't have the "translate" system in them. When I arrive a quiz... I will ask you how to manage it!

For example here, @Ragesoss... I don't know how the button is inserted: https://outreachdashboard.wmflabs.org/training/editing-wikipedia/wikipedia-essentials/notability-quiz

I have copied the code to my sandbox and, evidently, is not there!

@Theklan here's a quiz: https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides/10309-five-pillars-quiz-1

For translation, you can see some examples from the Support & Safety trainings: https://meta.wikimedia.org/wiki/Training_modules/Keeping_events_safe/slides/participants

Basically, you just mark the page for translation using the standard Meta translation tools.

@Ragesoss: Just finished with the first bunch, it seems that the previous one are missing (maybe only the link is missing). How could I continue with more?

@Ragesoss: Just finished with the first bunch, it seems that the previous one are missing (maybe only the link is missing). How could I continue with more?

Awesome, thanks! I just switched it over to use the on-wiki content for the 'Wikipedia Essentials' module. It should be ready for enabling translation now.

I added the first few links for the next module: https://outreachdashboard.wmflabs.org/training/editing-wikipedia/editing-basics/welcome-new-editor -> https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides-test

Elitre added a subscriber: Elitre.Aug 23 2017, 8:55 AM

Hi @Ragesoss! I added all the modules of the second tutorial. Whenever you want, put the first slide of the 3rd, 4th, 5th... and I'll will continue with it.

I have three formatting doubst:

1- The overtitle texts (as in video)... I have put them bold
2- The buttons and tutorials... I only inserted the link, but don't know how to translate this navigation tutorials (that are cool)
3- The videos... inserted only the youtube link

@Theklan thanks so much! For the videos, here is an example of how to format it: https://meta.wikimedia.org/wiki/Programs_%26_Events_Dashboard/Using_the_Dashboard/Basics/Logging_in

For the others, I may need to do some more work to get all the formatting templates ready. I'll take a look soon.

I added the first slide links for the rest of the modules: https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides-test

Ok! I think that all are there now, @Ragesoss! Now I will start with the <translate> notation. I did nothing with videos and special markup, as I would need to search for the videos in commons and some of you will make it faster.

I inserted the <translate> notation on a bunch of items but can't get the translation interface. Does someone know something about this?

After the translate tags are added, someone with the required user rights must enable the the page for translation: https://meta.wikimedia.org/wiki/Translation_requests

I'm (slowly) working through the slides to fix up the images, videos and buttons. I should be finished with the 'Editing Basics' module soon; after that would be a good time to get translation enabled for that module.

All the modules have been ported over to Meta and cleanup up now. :-)

Great! It seems that someone has to put them for translation, isn't it? I marked them, but that doesn't give results.

Yes. You should request for some of them to me marked for translation, following the instructions on that Translation requests page.

This translations will be done by @Inaki-LL and @Xabier.Armendaritz. Any question you have, @Ragesoss is your man!

Xabier.Armendaritz added a comment.EditedOct 20 2017, 10:26 AM

Hi @Theklan and @Ragesoss,

We (both @Inaki-LL and I) want to translate into Basque all the slides of the "Editing" section located here:
https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides

Which is the procedure? Should we create an "/eu" page for each URL contained in that section? For example: to translate the page
https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides/10901-evaluating
should we create the page
https://meta.wikimedia.org/wiki/Training_modules/dashboard/slides/10901-evaluating/eu
so that there is a Basque version?

When translating "Using the Dashboard" (https://meta.wikimedia.org/wiki/Programs_%26_Events_Dashboard/Using_the_Dashboard), the procedure was much simpler: there was a "Translate this page" (in Basque: "Itzuli orri hau") at the beginning of the page — but I can't find such link in the Slides pages. Perhaps someone with the required user rights must enable those pages for translation? If so, where should we request that they enable those pages for translation?

Base added a comment.Oct 20 2017, 2:57 PM

Are there some special requirements to marking of those pages? I opened a couple and see that they do not have <languages/> — is this deliberate? Must <noinclude> be used to add it? I can help with translate admin part if it is still needed but I need to make sure that the normal way of doing stuff would work well with dashboard.

@Base there aren't any special requirements except for putting <languages /> inside noinclude tags. Other than that, the normal way of doing it should work fine.

@Ragesoss Hi! I'm using the training modules to teach myself how to use the Dashboard and I was wondering, are translations made on Meta fetched and then published on https://outreachdashboard.wmflabs.org/training or is browsing the documentation on Meta the only way to read it in another language? That provides a better interface, presentation and navigation than Meta-wiki, in my opinion.

I was thinking of translating the training modules as I take them so that's why I'm bringing this up again. :)

@contraexemplo: updated translations from Meta can fetched and published on the Dashboard, but it does not happen automatically. To update the translations, you visit this URL, with the relevant module as the parameter: https://outreachdashboard.wmflabs.org/reload_trainings?module=using-the-dashboard

@Theklan Was the translation work completed? If so I'll close this task as resolved.

@Samwalton9 No, the issue is still there and no one seems to care. We hace a one year work translating everything but we can't use it property because titles can't be translated.

@Theklan Sorry to hear that - which pages are you attempting to translate? It's not clear to me from the above conversation.

We can't translate the training modules titles and first page, for example.

Samwalton9 renamed this task from How to translate training modules in the Programs & Events Dashboard? to Support translation of first page and title of training modules.Oct 30 2018, 1:27 PM
Samwalton9 updated the task description. (Show Details)

Looks like this task strongly overlaps with T180101, and there's a Github issue for the title part at https://github.com/WikiEducationFoundation/WikiEduDashboard/issues/1514.

Elitre removed a subscriber: Elitre.Nov 8 2018, 5:03 PM
Ragesoss closed this task as Resolved.Apr 23 2019, 10:17 PM
Ragesoss claimed this task.

The title and module description can be translated now. See, for example, https://outreachdashboard.wmflabs.org/training/support-and-safety/keeping-events-safe?locale=fr

Where can we translate it? Thanks!

@Theklan If you go to the 'wiki source' page for the module from the link at the end of the table of contents — for the example above, https://meta.wikimedia.org/wiki/User:JSutherland_(WMF)/dashboard_modules/keeping_events_safe.json — then you can see the "wiki_page" that contains the title and description of the module: https://meta.wikimedia.org/wiki/Training_modules/Keeping_events_safe/description

Many of the these pages haven't been set up for translation, but the Dashboard is all set to show translations once they are available.

If there are module pages that don't have a wiki_page field, we can start one and add it.

For that example, this is the page that needs to be set up for translation and then translated: https://meta.wikimedia.org/wiki/Training_modules/wikipedia-essentials

Currently is not possible, then! Ok... let's wait!