Page MenuHomePhabricator

There is no search button in Revision history of pages
Closed, DeclinedPublic

Description

Description:
We have no button to launch the history of any page after we change search options.
Also no buttons to display next or previous changes. That is abnormal.
In MediaWiki 1.30.0-wmf.14 (rMWe993fed5a26e) 02:39, 18 August 2017 or perhaps before (because I rarely search in histories of pages.)

Steps to reproduce:
Open the history of a page, example: history of one page.
Try to change search options and to launch the history.
Try to search older changes, or previews changes.

Expected outcome:
A search button permit to launch the modified history.
A next button permit to display older changes.
A previous button permit to display newer changes.

Actual outcome:
Without these buttons, the use of history is abnormaly limited.

Event Timeline

Rical created this task.Aug 21 2017, 3:30 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 21 2017, 3:30 PM
Aklapper changed the task status from Open to Stalled.Aug 21 2017, 6:13 PM

Hi @Rical, please read and follow T173404#3527154 and T165000#3254233 for how to structure your bug reports. Thanks.

Rical triaged this task as High priority.Aug 21 2017, 6:41 PM

Is it so difficult to try to use the history of any page?
This stalled task delays its debug and that disturbs many users.

Either I can't reproduce the issue you're describing or I don't understand your report. I see the "Show" button, and I see the pagination.

Is it so difficult to try to use the history of any page?

If you cannot provide clear steps to reproduce, expected outcome, actual outcome: Yes, as there are often more factors involved than you think. See the last comment.

This stalled task delays its debug and that disturbs many users.

Then please provide good bug reports. Problems that others can reliably reproduce (thanks to proper steps to reproduce) can normally get fixed faster.

Rical updated the task description. (Show Details)Aug 22 2017, 8:30 AM
Aklapper changed the task status from Stalled to Open.Aug 22 2017, 8:35 AM
Aklapper lowered the priority of this task from High to Lowest.Aug 22 2017, 8:39 AM

About buttons to view more diffs, you are rigth, that depends on the number of diffs.

Also tried: the "Show" button do not replace the missing button "Search".

I'm pretty sure there never was a "Search" button on history pages, only "Show".

Also tried: the "Show" button do not replace the missing button "Search".

I don't understand what you mean here?

I tried some ways to see modified history, even unattended.
A normal case is to ask that:

  1. Display the history of a page. 2) Change month/year to 2017/july.

How do you activate this change to display the new history?

Aklapper changed the task status from Open to Stalled.Mon, Aug 12, 5:00 PM

"Filter revisions" ("Filtrer les versions") offers setting a max date. After I set the date to a day in December 2018 on https://fr.wikisource.org/w/index.php?title=MediaWiki:Scribunto/Central_modules_reference_manual&action=history , the list of changes is updated accordingly. There are still all buttons / options available that I'd expect.

@Rical If that's not the case for you then please provide a screenshot and be more specific what "Try to change search options and to launch the history" means exactly.

Rical closed this task as Resolved.Mon, Aug 12, 6:22 PM
Rical claimed this task.

This task is so old that I do not remenber what was my own question.
When I try today a versions story all seems OK.
Then I close this task.

Aklapper changed the task status from Resolved to Declined.Mon, Aug 12, 6:58 PM
Aklapper removed Rical as the assignee of this task.

Thanks for the quick reply!

This task is so old that I do not remenber what was my own question.

I guess you answered T173730#3539243 yourself now why clear steps to reproduce can be useful. :)