Page MenuHomePhabricator

RevisionJumper gadget: "Next to last editor" diff link broken
Closed, InvalidPublic

Description

This is very likely related to the rollback gadget. When a user has made multiple edits and I view a diff of their most recent edit, I also see a link to bring up a diff of all the edits performed by the user in question against the last edit of the previous editor. This link is titled "← next-to-last editor". Until a few weeks ago, it was working fine. Now however, it appears to compare the edit with the current edit (usually itself) rather than the last edit of the next-to-last editor.

I also have Twinkle installed and this functionality is similar to its "Since" option. This option still works fine.

Thanks.

Edit:

Steps to reproduce:

  1. On this diff page, you can see a diff by Miniapolis. This is the difference between 1 revision. The user has made a series of revisions. I have an option, presumably created by the rollback gadget, to view a diff of not just 1 edit, but all the edits performed by this user (in this series of edits). This option is provided by a link entitled, "← next-to-last editor".
  2. The "← next-to-last editor" would/should normally link to this diff, but instead links to this one which is quite useless.

While I was pretty sure that Twinkle handles this correctly, it appears that the "Since" function is not much better. Perhaps the issue is that these diffs are not comparing the "latest" edit. In any case, these labels are confusing.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 22 2017, 10:38 AM
Aklapper changed the task status from Open to Stalled.Aug 22 2017, 10:48 AM

Hi @Cpt.a.haddock, thanks for taking the time to report this!
Unfortunately this report lacks some information. If you have time and can still reproduce the problem: Please add a more complete description to this report (a list of steps to reproduce which leave no room for interpretation what to do, describing actual results and expected results after performing the steps to reproduce, attaching or linking to a public testcase). Does this refer to some Wikimedia website? Or some private MediaWiki installation? Where to see that "rollback gadget"?
You can edit the task description by clicking Edit Task.
Ideally, exact and clear steps to reproduce should allow any other person to follow these steps (without having to interpret those steps) and see the same results. Problems that others can reliably reproduce can get fixed faster. Thanks!

Updated. Thanks.

This option is provided by a link entitled, "← next-to-last editor".

I do not see such a link. :(
I cannot find anything called "rollback" on https://en.wikipedia.org/wiki/Special:Preferences#mw-prefsection-gadgets either.
Hence it's unclear to me how to reproduce the problem.

(Also note: If this is a gadget issue, it will have to be fixed on-wiki by the community, and as far as I know the English WP gadget maintainers do not use Phabricator to track gadget issues.)

Ah. This seems to be offered by the RevisionJumper gadget. I'm CC'ing its author here but I'm afraid you will have to report this on https://en.wikipedia.org/wiki/User_talk:DerHexer/revisionjumper instead of Phabricator, sorry, as the gadget is not managed on Wikimedia Phabricator...

Aklapper renamed this task from "Next to last editor" diff link broken to RevisionJumper gadget: "Next to last editor" diff link broken.Aug 24 2017, 5:25 PM
Aklapper closed this task as Invalid.

Thank you. I thought this was something enabled once a user was given rollback rights. I do have that gadget enabled. Apologies for wasting your time.

Oh, no no, please. No time wasted! :) Happy we could track this down a little bit at least!

Indeed, thanks for helping! :)