Page MenuHomePhabricator

Enable EchoPerUserBlacklist on all Wikimedia wikis with Echo enabled
Closed, ResolvedPublic2 Story Points

Description

Enable EchoPerUserBlacklist T150419: Allow users to restrict who can send them notifications on all Wikimedia wikis that have Echo enabled.

This can be done by adding this to LocalSettings:

$wgEchoPerUserBlacklist = true;

Event Timeline

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 22 2017, 2:57 PM
dbarratt renamed this task from Enable Echo Mute on all Wikimedia wikis with Echo enabled to Enable Echo Per User Blacklist on all Wikimedia wikis with Echo enabled.Aug 22 2017, 3:16 PM
dbarratt updated the task description. (Show Details)
dbarratt updated the task description. (Show Details)Aug 22 2017, 3:18 PM
dbarratt added a subscriber: kaldari.

@kaldari Is there anything we need to do for this or will this be handled by Wikimedia-Extension-setup?

TBolliger renamed this task from Enable Echo Per User Blacklist on all Wikimedia wikis with Echo enabled to Enable EchoPerUserBlacklist on all Wikimedia wikis with Echo enabled.Aug 22 2017, 5:05 PM
TBolliger updated the task description. (Show Details)
kaldari set the point value for this task to 2.Aug 22 2017, 5:11 PM

@dbarratt: Yes, we need to submit the configuration patch, schedule the deployment at https://wikitech.wikimedia.org/wiki/Deployments, and test immediately after the deployment. @Niharika can cover in more detail.

I wrote a bit on IRC earlier:

The ad-hoc deployments that happen on Wikimedia wikis are called SWAT deploys. They typically happen twice daily except on Friday (no SWAT deploys) and Tuesdays (no morning SWAT).

This is the deployment calendar: https://wikitech.wikimedia.org/wiki/Deployments Anything which cannot/should not go out as part of the weekly train has to be scheduled here.

All of the config code for what's deployed where can be found in the mediawiki-config repo. If you search for wgEchoPerUserBlacklist, you'll find it to be present in InitialiseSettings.php (warning: huge file!)

'wgEchoPerUserBlacklist' => [
	'default' => false,
	'metawiki' => true,
],

That array defines where the feature is enabled. So you want to change that array to something like:

'wgEchoPerUserBlacklist' => [
	'default' => true,
	'nonecho' => false,
],

'nonecho' is a dblist with a list of wikis where Echo is not enabled. So we'll skip any wiki without Echo when enabling this feature.

To start with, someone make the patch! (and claim this ticket if you're doing so)

Urbanecm claimed this task.Aug 22 2017, 7:21 PM
Urbanecm added a subscriber: Urbanecm.

There's no problem with submitting the patch for me :). Is this still waiting for T168902 ?

Restricted Application added a project: User-Urbanecm. · View Herald TranscriptAug 22 2017, 7:21 PM

Change 373133 had a related patch set uploaded (by Urbanecm; owner: Urbanecm):
[operations/mediawiki-config@master] Enable wgEchoPerUserBlacklist at all wikis

https://gerrit.wikimedia.org/r/373133

Niharika added a subscriber: dmaza.Aug 22 2017, 8:51 PM

There's no problem with submitting the patch for me :). Is this still waiting for T168902 ?

Whoops, I should have clarified that this task was intended as a tutorial for @dmaza and @dbarratt who are both new to deployments. :)

Thanks for the patch. I guess one of them can take it from here. I don't know if this is still blocked on T168902 though.

I'm sorry then, I saw a task that I can do so I claimed&uploaded a patch :). I'll leave this task then.

Thanks for the patch. I guess one of them can take it from here. I don't know if this is still blocked on T168902 though.

So what's next?

I'm sorry then, I saw a task that I can do so I claimed&uploaded a patch :). I'll leave this task then.

No problem! Thanks for the patch!

Let's merge and release!

Thanks for the patch. I guess one of them can take it from here. I don't know if this is still blocked on T168902 though.

So what's next?

You need to schedule this task on the Deployment calendar. There's two windows today - 1100 and 1600 PST. Pick the one when you're free.

Second, download the WikimediaDebug extension on Chrome (or FF).

Third, join the #wikimedia-operations channel and when the deployer asks you to test your patch on mwdebug1002, you turn on the extension and pick mwdebug1002 from the dropdown and test your change in production.

Ping me on IRC if something's not clear. :)

@dbarratt: Here's more detailed info on using the debug extensions: https://wikitech.wikimedia.org/wiki/X-Wikimedia-Debug

Don't you think this is kind of premature. Once we have it on multiple wikis, migrating to an global-only setting will become much harder.

jrbs moved this task from Backlog to Other team on the Trust-and-Safety board.Aug 24 2017, 7:40 PM

Don't you think this is kind of premature. Once we have it on multiple wikis, migrating to an global-only setting will become much harder.

Yes it will be more difficult to migrate if we build T167902: Build a unified, cross-wiki Mute feature for multiple types of on-wiki and email communication , but our team discussed and believe we can provide immediate value with two separate lists this quarter, evaluate how they are being used, then re-consider T167902.

  • Put us on the schedule
  • Install the extension
  • Join #wikimedia-operations
dbarratt claimed this task.Aug 25 2017, 5:04 AM
dbarratt moved this task from Ready to In progress on the Anti-Harassment (AHT Sprint 3) board.

Change 373133 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable wgEchoPerUserBlacklist at all wikis

https://gerrit.wikimedia.org/r/373133

Mentioned in SAL (#wikimedia-operations) [2017-08-28T18:21:43Z] <niharika29@tin> Synchronized wmf-config/InitialiseSettings.php: Enable wgEchoPerUserBlacklist at all wikis T173838 (duration: 00m 43s)

dbarratt closed this task as Resolved.Aug 28 2017, 6:25 PM
dbarratt moved this task from In progress to Done on the Anti-Harassment (AHT Sprint 3) board.