Page MenuHomePhabricator

Scrolling the translation editor makes the publish button unreachable
Closed, ResolvedPublic

Description

Content Translation keeps a sticky toolbar on top in order to provide access to options regardless of the user having scrolled down the document. The publish button used to be available as part of the sticky header. Currently a regression seems to cause the publish button to no longer be there:

Before scrollAfter scroll

The publish button should remain on the sticky header in order to be reachable regardless of users scrolling down the document.

(This was tested by translating "Tree" from English to Spanish)

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 25 2017, 9:00 AM
Pginer-WMF updated the task description. (Show Details)Aug 25 2017, 9:00 AM
Pginer-WMF added subscribers: santhosh, Amire80.

This is a regression

Pginer-WMF added a comment.EditedOct 27 2017, 5:05 AM

As we fix this we may want to implement the new location for the publish button (T160068: Integrate publish button into the document area of the translation view) instead of restoring the old one.

Arrbee triaged this task as Normal priority.
Arrbee added a project: Language-2017-Oct-Dec.

This regression was caused by https://gerrit.wikimedia.org/r/#/c/346799/ Where @Esanders added VE tool bar and made it sticky.

Change 396281 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] CX1: Make header bar on translation view sticky again

https://gerrit.wikimedia.org/r/396281

This regression was caused by https://gerrit.wikimedia.org/r/#/c/346799/ Where @Esanders added VE tool bar and made it sticky.

Yep, that commit was only intended for CX2. Apologies.

Change 396281 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] CX1: Make header bar on translation view sticky again

https://gerrit.wikimedia.org/r/396281

Etonkovidova closed this task as Resolved.Jan 3 2018, 8:00 PM
Petar.petkovic moved this task from QA to Done on the Language-2017-Oct-Dec board.Jan 3 2018, 11:47 PM