Page MenuHomePhabricator

Phlogiston should allow treating some categories as if they were resolved
Closed, ResolvedPublic5 Story Points

Description

Several teams allow completed work to pile up in a "Done" column for a long time before resolving. Some teams use a "Done" tag to indicate that tasks are resolved. Phlogiston should have a way to indicate that some categories should be treated as resolved.

This could be that each category rule could have a flag indicating that it is resolved, or there could be a new "Treat the following categories as resolved" rule type.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 25 2017, 5:38 PM
JAufrecht added a subscriber: JAufrecht.

Phlogiston's internal model has a text field for status which by convention (but not enforced) is only open or resolved. All tasks with status open and stalled are assigned open; tasks which are resolved stay resolved, and duplicate, declined, invalid are deleted.

The proposed design of using category rules to modify status makes sense. How generic should it be?
a) "MAKE_RESOLVED" flag. If true, everything matching this rule is made resolved.
b) "FORCE_STATUS" text field. if "open", change all matching tasks to open. If resolved, to resolved. Any other value, or blank, or False, don't change status.
c) As b but allow any text string in status.

I vote for d) As b, but throw an error if the string is anything other than "resolved".

That allows us to do what we want for now, quickly indicates if we screwed up, and gives us the flexibility to do something more interesting in the future, without adding yet another flag/command.

Second choice would be a, because I dislike the "silent failure" modes of b and c.

JAufrecht moved this task from To Be Triaged to Reporting on the Phlogiston board.Sep 13 2017, 6:48 PM
JAufrecht edited projects, added Phlogiston (Reporting); removed Phlogiston.
JAufrecht set the point value for this task to 5.Sep 15 2017, 9:18 PM

Implemented on dev, tested with vec, and rolled to production. Documented here:

https://www.mediawiki.org/wiki/Phlogiston/Configuring#Force_status

please test.

@JAufrecht I don't know of any teams that use this (TPG was the one that came to mind). Know of one that I can use to test?

Testing on the Doing column of "pana" because it's a short report

I don't know if I'm setting it up wrong, but I can't get this to work. I added this to pana_recategorization.csv:

ProjectColumn,Doing Test T174183,SHOW,3313,Doing,resolved

And "Recently closed tasks" only shows 2 tasks even though there are 21 in the targeted column. Tried after running "rerecon" and also "report".

JAufrecht claimed this task.Aug 7 2018, 7:52 PM
JAufrecht edited subscribers, added: MBinder_WMF; removed: ksmith.
JAufrecht reassigned this task from JAufrecht to MBinder_WMF.Aug 8 2018, 6:01 PM

The first rule was catching everything, I think, and not leaving any tasks for the "Doing Test T174183" rule to operate on. I moved that rule (and the "Tracking" rule) higher, and it appears to work.

Not sure what happened to recently closed, but the database has been completely rebuilt and it looks much longer now since it now shows everything caught by the Doing Test rule.

Please review.

http://phlogiston-dev.wmflabs.org/pana_report.html

MBinder_WMF closed this task as Resolved.Aug 14 2018, 10:28 PM

So far it looks to be fine. Tasks moved to the test column after 2018-07-01 are marked as Done in Status Report. Tasks that were moved to this column before this date are omitted from status report. Example:
https://phabricator.wikimedia.org/T184677

I believe this is by design.

Tasks that are Done at the start of the status report and Done at the end of the status report are omitted (or else all resolved tasks would be on every status report). This includes tasks that are open in the middle of the report period but not the start or end.

Tasks that are Done at the start of the status report and Open at the end get the status "Reopened"