Page MenuHomePhabricator

Notifications do not work at Mac OS for Mates@cswiki
Closed, InvalidPublic

Description

Hello,

I was told that notifications do not work at Mac OS for @Mates at cswiki in Safari (in Chrome everything is normal). They just do not open. At other wikis all works as normally. Safemode, inkognito browser and another on-wiki user made no difference. I tried it at my own Mac (I was logged in as Wikipedista XY), everything worked normally.

Several other things do not work (for example the edit toolbar isn't showed). Let me know if I should create other tasks for those other things or we'll use this one as all-in-one. As it is significantly marking wiki-work harder, marking as UBN.

Screenshots of console

Logged in as Mates (normal account), w/o inkognito window

Logged in as Mates245 (another account), with inkognito window

Details of console windows

Event Timeline

Urbanecm created this task.Aug 26 2017, 1:07 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Urbanecm triaged this task as Unbreak Now! priority.Aug 26 2017, 1:07 PM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptAug 26 2017, 1:07 PM
Urbanecm moved this task from Backlog to Watching on the User-Urbanecm board.Aug 26 2017, 1:09 PM
Samtar added a subscriber: Samtar.Aug 26 2017, 1:15 PM

@Urbanecm How many people affected? Have you tested this with Safari on your own Mac? If it's working for everyone bar one user, the priority should not be UBN.

What is @Mates ' version of MacOS, and version of Safari? If you've tested with MacOS and Safari, what are your versions?

Urbanecm added a comment.EditedAug 26 2017, 1:19 PM

@Urbanecm How many people affected? Have you tested this with Safari on your own Mac? If it's working for everyone bar one user, the priority should not be UBN.

If even only one user is affected so he can't do anything at all, it is UBN from my point of view. I tested it at my Mac, it worked (by the way, I noted it in the task description ;)).

What is @Mates ' version of MacOS, and version of Safari? If you've tested with MacOS and Safari, what are your versions?

My version details

  • Safari: 10.0.3
  • Mac OS version: 10.10.5 OS X Yossemite

Mates's version details

  • Safari 9.1.1 (11601.6.17)

The user reported that it isn't working since Thursday, August 24 (there was a MW train on all Wikipedias, including cswiki). Can't it be caused by the WMF release?

wmf.15 was rolled 24th, and did have changes relating to echo (https://www.mediawiki.org/wiki/MediaWiki_1.30/wmf.15#Echo)

Could you get Mates to walk us through exactly what isn't working? In the task you describe it as "They just do not open" - if Mates clicks on the echo icons do they open the drop down as expected?

wmf.15 was rolled 24th, and did have changes relating to echo (https://www.mediawiki.org/wiki/MediaWiki_1.30/wmf.15#Echo)

Good to know.

Could you get Mates to walk us through exactly what isn't working? In the task you describe it as "They just do not open" - if Mates clicks on the echo icons do they open the drop down as expected?

I've asked Mates what exactly happened when he click on the echo icons. He said: "Nothing. It is like the icons aren't displayed. I can open them in a new tab. If there is a new notification and I click at it, the notifications just turn grey, nothing else.".

Urbanecm closed this task as Invalid.Aug 26 2017, 3:12 PM

Mates updated his operating system. Everything is working as-expected. Hence marking as Invalid.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptAug 26 2017, 3:12 PM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 18 2018, 11:48 AM