Page MenuHomePhabricator

LintErrors conflicts with SyntaxHighlighter
Closed, ResolvedPublic

Description

Steps to reproduce

  1. Make sure SyntaxHighlighter is on and ready
  2. Open Special:LintErrors
  3. Choose a category, click on Edit next to an article

Expected behavior
Page text should be opened, syntax should be highlighted and then a broken part marked

Current behavior
Page text is opened, broken part is marked and finally syntax is highlighted, which clears marked part and therefore there is no text marked by Linter

Event Timeline

Dvorapa created this task.Aug 28 2017, 10:50 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 28 2017, 10:50 AM
Dvorapa updated the task description. (Show Details)Aug 28 2017, 10:51 AM

Seems should be fixed with T174547

I'm not convinced, we'll see soon

Niharika triaged this task as Lowest priority.Nov 7 2017, 11:40 PM
Restricted Application added a project: Community-Tech. · View Herald TranscriptNov 7 2017, 11:40 PM
Legoktm closed this task as Resolved.Nov 25 2017, 11:18 PM
Legoktm assigned this task to Pastakhov.
Legoktm added a subscriber: Legoktm.

Just tested this on the English Wikipedia and it works for me.