Page MenuHomePhabricator

Remove non-image file types from print
Closed, DeclinedPublic

Description

Background

Currently, animations in articles are not printing (for obvious reasons).

https://phabricator.wikimedia.org/T172184#3516753
http://reading-web-staging.wmflabs.org/wiki/Trigonometric_functions

Acceptance criteria

Is there a way we can remove these from print altogether? Here it's a gif, but we might want to just exclude all file types that aren't image types.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 28 2017, 1:33 PM
ovasileva renamed this task from Remove animations from print to Remove non-image file types from print .Aug 28 2017, 1:33 PM
ovasileva triaged this task as High priority.
ovasileva added subscribers: Jdlrobson, Nirzar.

I'd advise against removing content like this - it's going to be extremely hacky. The problem is that many articles refer to images (e.g. See animation on left). I don't think we can reliably scrub them.

Is this really a big deal?
"High priority" seems a bit of an overreaction to me. I don't think users printing will understand if the animations are static and do not work on their printed PDF.. :)

I'd advise against removing content like this - it's going to be extremely hacky. The problem is that many articles refer to images (e.g. See animation on left). I don't think we can reliably scrub them.

Not all articles refer to the animation and even if they do, they refer to a broken image on the printed page. The gain might not be high, but I think removing them will still decrease the overall amount of confusion.

Is this really a big deal?
"High priority" seems a bit of an overreaction to me. I don't think users printing will understand if the animations are static and do not work on their printed PDF.. :)

We can revisit the priority based on technical difficulty, but I think we should fix as many of the larger/legitimate bugs with the print styles prior to deploying the new ones. Hence, most of these will be high priority upon creation.

We can revisit the priority based on technical difficulty, but I think we should fix as many of the larger/legitimate bugs with the print styles prior to deploying the new ones. Hence, most of these will be high priority upon creation.

I don't think we have a shared definition of "high" and we might want to talk about this.

If you tag something "high" I will drop everything to look into the task (even if at the expense of something I'm working on at the sprint board)... I get notifications on high tasks. Per https://www.mediawiki.org/wiki/Phabricator/Project_management#Priority_levels "high" tends to mean "this needs to be fixed this week".

So working on that assumption, I had a look into this and in terms of technical difficulty, this is extremely difficult; potentially impossible.. we'd need some way of detecting whether an image was an animation via CSS which we don't currently have.

Best we could do is check file type e.g. gif to hide the image but even then we'd still have to trade off and show empty gray boxes (which might look even stranger) like so (there are no parent selectors in CSS):

ovasileva closed this task as Declined.Sep 5 2017, 11:19 AM

Declining this for now, based on https://phabricator.wikimedia.org/T172184#3578283