Page MenuHomePhabricator

30 Audio WebM files on Commons marked as MEDIATYPE_VIDEO
Closed, ResolvedPublic

Description

SELECT img_name
FROM image
WHERE img_media_type="VIDEO"
AND img_major_mime="video" AND img_minor_mime="webm"
AND img_metadata LIKE '%s:9:"mime_type";s:10:"audio/webm";%';
img_name
Abadilla_from_Philippines_pronunciation_(Voice_of_America).webm
Ancora_un_passo.webm
Badonviller_-_U.S._Marine_Band.webm
Clywch_Clywch_Newyddion_Gorau_Partir_Berfeddwlad_Llanrwst_2016.webmsd.webm
Daeth_Nadolig_fel_Arferol_Parti_Llanrwst_2016.webmsd.webm
Domingo_Iturbe_Abasolo_from_Spain_pronunciation_(Voice_of_America).webm
Dyma'r_dydd_y_ganed_Iesu_Llanrwst_2016.webmsd.webm
Egil_Aarvik_from_Norway_pronunciation_(Voice_of_America).webm
Entrevista_Josep_Lluís_Carod_Rovira_(256kbit).webm
Fira_del_Llibre_2016_Felip_Bens_-_El_cas_Forlati.webm
Fru_Herber.webm
Hörprobe_Morgenfreude.webm
Ich_geh_mit_meiner_Laterne.webm
Instrumental_Oriental_Music_of_India.webm
Jorge_Abadia_from_Panama_pronunciation_(Voice_of_America).webm
Leonid_Abalkin_from_Russia_pronunciation_(Voice_of_America).webm
Marco_Raaphorst_10y_3VOOR12-leader.webm
Mignon-_'Non_conosci_il_bel_suol'.webm
Obama2009HRCSpeechPart1.webm
Ouz.webm
Parti'r_Berfeddwlad_Plygain_Llanrwst_Pan_oedd_y_Baban_Iesu.webmsd.webm
Parti_Llanfair_Deffrown_Deffrown_Llanrwst_2016.webmsd.webm
Sain_Hedd_Mewn_Preseb_Llwm.webmsd.webm
Sain_Tramwywn_Hedd_a_Robin_Llanrwst_2016.webmsd.webm
Sani_Abacha_from_Nigeria_pronunciation_(Voice_of_America).webm
Sarrionaindia_Korrika.webm
Silja_Opera_Kustaanmiekka_strait.webm
Teetar_Bird_Calls.webm
Un_bel_di_vedremo.webm
Zarna.webm

Event Timeline

Restricted Application removed a project: Patch-For-Review. · View Herald TranscriptAug 28 2017, 8:22 PM
Restricted Application added subscribers: jeblad, Danmichaelo, jhsoby. · View Herald Transcript
TheDJ added a comment.Aug 29 2017, 9:56 AM

Have we tried purging these files ?

Aklapper renamed this task from 30 Audio WebM file marked as MEDIATYPE_VIDEO to 30 Audio WebM files on Commons marked as MEDIATYPE_VIDEO.Aug 29 2017, 11:14 AM
Aklapper removed a project: MW-1.30-release-notes.
Ramsey-WMF moved this task from Untriaged to Next up on the Multimedia board.Oct 9 2017, 5:14 PM
Ramsey-WMF added a subscriber: Ramsey-WMF.

Hi, @Dispenser . Are you just concerned about these 30 files or are there potentially many more that we're missing?

These 30 image entries, along with 4 oldimage and 94 filearchive entries have been fixed.
The root cause was already addressed earlier (T156135)

The query blocked the image table for 5 minutes https://grafana.wikimedia.org/dashboard/db/mysql?orgId=1&var-dc=eqiad%20prometheus%2Fops&var-server=db1053&var-port=9104&from=1508243685418&to=1508248037877 either blocking edits or making them likely to fail for 10 minutes: https://grafana.wikimedia.org/dashboard/db/mysql-replication-lag?panelId=4&fullscreen&orgId=1&from=1508237088740&to=1508249466685&var-dc=eqiad%20prometheus%2Fops

The edit was not logged, a backup was not asked in advance, not it was scheduled on the deployments page.

I would like to ask for the writing of an incident report: https://wikitech.wikimedia.org/wiki/Incident_documentation to see how we can avoid it in the future.

TheDJ added a comment.Oct 17 2017, 2:33 PM

"have been fixed".. for future reference... how? was it indeed needed to run a purge script ?

I would like to ask for the writing of an incident report: https://wikitech.wikimedia.org/wiki/Incident_documentation to see how we can avoid it in the future.

@matthiasmullie: Could you clarify whether you (or anyone else) has plans to do so, and also reply to TheDJ's last question? Thanks in advance!

jhsoby removed a subscriber: jhsoby.Nov 2 2017, 3:34 PM
ABorbaWMF closed this task as Resolved.Nov 3 2017, 10:32 PM
ABorbaWMF added a subscriber: ABorbaWMF.

This appears to be fixed. I check about half of the audio files listed above and they appear to be audio files when viewed/played on commons.

I had updated these directly in the database, with a horrible query (https://wikitech.wikimedia.org/wiki/Incident_documentation/20171017-webm-audio-mediatype)
We shouldn't need to do this again (and definitely not this same way) since the root cause has already been fixed a while ago.