Page MenuHomePhabricator

Relaunch Geohack mobile maps gadget experiment on English Wikipedia
Closed, DeclinedPublic

Description

Goal:
Quickly gather information about engagement with coordinates and maps on mobile

What:

  • Enable the gadget for everyone (anonymous and users) for a 2 to 4 week run.
  • Gather data on engagements with the coordinates and the map button on mobile web (and overall tile usage)
  • Announce on en.wp village pumps ?

Gaps in approach:

    • No full design cycle (might not be the most enticing way to have users interact with this information)
    • JS based
    • No coverage of mobile apps
  • Probably hard to compare to desktop numbers, due to multitude ways that we offer desktop users this information

Benefits:

  • low impact on desktop users
  • low investment by both WMF and volunteers
  • big enough pool of users to get usable data from

Previously raised concerns
So to reiterate:

  1. Payload size concerns
    1. Alleviated by avoiding oojs ui widgets
    2. Only affected location pages, which should be 4% of our pageviews (according to JKatz)
  2. Concerns regarding Sierra Leone tiles
    1. Could be a Kartotherian issue
    2. Could be a connection problem
    3. Could be an overload due to increased usage ?
      1. I do not see a major increase in resource usage in grafana, though it does seem there was a half to 1 million served tiles 'bump' when the gadget was active.
    4. Regardless, this seems likely to be serverside, if anything, so not directly related to the gadget
  3. Amire reported issues with Firefox
    1. These issues cannot be reproduced
    2. No logging is available from the problems.
  4. Gadgets don't work for anymous mobile users
    1. We can avoid this by loading from MediaWiki:Mobile.js instead
  5. The default gadget throws a non-problematic console error
    1. We can avoid this by loading from MediaWiki:Mobile.js instead
    2. This issue is fixed now https://gerrit.wikimedia.org/r/#/c/376036/
  6. Is ops aware of increased tile server usage and could it be a problem
    1. Ops is aware now
    2. Everyone seems to agree that the increased usage should not be a problem
  7. The addition of the map logo causes a repaint and a reflow
    1. The reflow has been dealt with
    2. The repaint can only be solved by moving the code completely into the extension
      1. For a limited time, it might be reasonable
      2. Might even increase engagement, by the button being more noticeable.
  8. What's the impact for lower end devices ?
    1. I would say it's the same as for people visiting wikivoyage pages with maps.
    2. Do we have any defences to these kinds of problems to begin with ? Can we identify a performance group and exclude them from certain functionality ?

Event Timeline

TheDJ created this task.Aug 30 2017, 9:56 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 30 2017, 9:56 AM
TheDJ updated the task description. (Show Details)Aug 30 2017, 10:18 AM
TheDJ updated the task description. (Show Details)Sep 6 2017, 1:21 PM
TheDJ added a comment.Sep 15 2017, 3:51 PM

I'll just sigh about me not having gotten around to this yet, 4 weeks after Wikimania :)

TheDJ removed TheDJ as the assignee of this task.Nov 8 2017, 1:04 PM

Unassigning as I promised myself to not work on things that take more than 4 hours.

@TheDJ, this tasks reads to me as kind of a big task. Would it be beneficial to break up the remaining work into smaller sub tasks? Not specifically for your own sanity, but maybe if others want to come along and help out?

TheDJ closed this task as Declined.Jan 4 2018, 10:25 AM

@CKoerner_WMF It really isn't that big a task, just requires attention. I wanted to run this experiment, because i failed on getting away with the first iteration of it, but truly believed in it. But I honestly can't take care of this (I probably contributed fewer lines of codes in the past half year, then I did during the entire wikimania week honestly).

So i think we should close it. The gadget is available as a PoC and for whoever wants to "gather information about engagement with coordinates and maps on mobile". But I think we all know that no one can take on the work right now to measure this as it is currently worded in the ticket.

Better to close in my opinion.

debt added a comment.Jan 4 2018, 3:46 PM

@CKoerner_WMF It really isn't that big a task, just requires attention. I wanted to run this experiment, because i failed on getting away with the first iteration of it, but truly believed in it. But I honestly can't take care of this (I probably contributed fewer lines of codes in the past half year, then I did during the entire wikimania week honestly).

So i think we should close it. The gadget is available as a PoC and for whoever wants to "gather information about engagement with coordinates and maps on mobile". But I think we all know that no one can take on the work right now to measure this as it is currently worded in the ticket.

Better to close in my opinion.

Thanks for all your work on this, @TheDJ :)

Echoing @deb, I too appreciate you work @TheDJ. Thank you for the clarity and closure. :)