Page MenuHomePhabricator

Transcluding a talk page on another page sends mention notifications for all the users on the page being transcluded
Closed, DeclinedPublic

Description

On Wikipedia, transcluding a page with links to userpages will send mention notifications. This, along with other problematic editing, got me blocked indefinitely. (This is not a request to appeal, this is just a bug report)


Actions done:

  • transclude a user talk page into the user user page sends notifications to all users listed on the talk page
  • transclude a user page into a user subpage to all users listed on the talk page

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 31 2017, 4:08 AM
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptAug 31 2017, 5:10 AM

Can you clarify how you have done this transclusion, @UpsandDowns1234 ? Do you have any links? Thanks!

I transcluded a userpage with a bunch of links to other's userpages into another userpage. Do this on Test Wikipedia, it got me blocked indefinitely on en.wikipedia

UpsandDowns1234 added a comment.EditedSep 5 2017, 9:30 PM

Also, see [//en.wikipedia.org/wiki/User_talk:Iridescent]

A list of steps to reproduce, step by step, as bullet points, which leave no room for any interpretation, is highly welcome, as issues that can be reliably reproduced have a higher chance to get fixed.

A step-by-step would be indeed very helpful. I've checked your contributions on test Wikipedia, @UpsandDowns1234 and found nothing.

Check on en.wikipedia.org. I have done it there, and I do not want to send mentions to the users here either.

@UpsandDowns1234, where am I supposed to check on English Wikipedia? Please provide at least precise links to:

  • the page that has all user names
  • the page you have transcluded the list into
  • the relevant diffs about those actions

My contribs (included my deleted ones). What I did was transcluded my user talk page into my user page, where mention notifs were sent. Then I transcluded my user page into a user subpage, where they were sent again. I left an apology on my talk page, but that was disruptive enough to get me blocked indefinitely from editing. I only have access to this diff (https://en.wikipedia.org/w/index.php?title=User:UpsandDowns1234/main.css&oldid=794971340). I transcluded the css file a while ago before doing this to my chat.

Trizek-WMF renamed this task from Transcluding a page on Wikipedia sends mention notifications for all the users on the page being transcluded to Transcluding a talk page on another page sends mention notifications for all the users on the page being transcluded.Sep 8 2017, 9:58 AM
Trizek-WMF updated the task description. (Show Details)
Trizek-WMF added a subscriber: Etonkovidova.
Legoktm closed this task as Declined.Sep 9 2017, 8:46 PM
Legoktm added a subscriber: Legoktm.

This is intentional. Without it, {{ping}} and co wouldn't work.

This is intentional. Without it, {{ping}} and co wouldn't work.

Without what? Can you explain?

Transcluding a talk page on another page sends mention notifications for all the users on the page being transcluded

If mentions through transclusions didn't work, then templates like {{ping}] which create mentions through transclusion wouldn't work. IIRC Echo already has some checks built in to not ping if over 50 people are mentioned in one edit or something. This ticket is technically a duplicate of the one that introduced that check I believe.