Page MenuHomePhabricator

One user can't use VisualEditor with Safari on a Mac
Closed, InvalidPublic

Description

An user on itwiki (here if you are interested in more infos) is reporting some issue with some browsers. He has a Mac with El Capitan 10.11.5. When he clicks on "Modifica" nothing happens, so he is forced to use "Modifica wikitesto". He has this problem when using Safari 9.1.1 (11601.6.17). When he uses Opera 41.0.2353.69 he can't edit image captions, but VE works fine. He has no problem using Opera Neon Version 1.0.2531.0 (64-bit) and Roccat Version 7.4 (7.4)

Event Timeline

Nnvu created this task.Aug 31 2017, 7:43 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 31 2017, 7:43 AM
Deskana renamed this task from Can't use VisualEditor with some browser to One user can't use VisualEditor with Safari on a Mac.Aug 31 2017, 11:50 AM
Nnvu added a comment.Aug 31 2017, 11:51 AM

I forgot to mention that he has the issue even when he tries to edit without logging in.

Deskana changed the task status from Open to Stalled.Aug 31 2017, 12:01 PM
Deskana added a subscriber: Deskana.

It sounds like his browser is messed up. The only reason I can think of for why this would happen is if Javascript were disabled, but in that case it wouldn't show him the tab to edit using VisualEditor nor the option to switch to VisualEditor.

Without more information, I have to assume the problem is on his end, and that there's nothing we can do about it.

Nnvu added a comment.Aug 31 2017, 12:31 PM

I asked the user if he can reset Safari to default preferences and try to edit

Nnvu added a comment.Aug 31 2017, 6:19 PM

@Deskana after restoring Safari, the issue is apparently solved. I asked the user to take note of every edit in the settings he makes and tell me if he sees that something causes the issue.

Deskana closed this task as Invalid.Aug 31 2017, 9:18 PM

@Nnvu Glad to hear it. Thanks. :-)