Page MenuHomePhabricator

Provide yearly update of stats for audit report
Closed, ResolvedPublic

Description

Previous years we reported these stats for audit report. Tony Le asked can we do this again this year, asap?

"For the year ended June 30, 2016, the educational content of the Foundation’s largest project, Wikipedia, grew by approximately 5.2 million articles to approximately 40.6 million articles total.

For the year ended June 30, 2016, volunteers added approximately 6.1 million images, movies, and sound files to the Foundation’s multimedia repository, making the total 33.1 million files.

Volunteers also contribute in several ways to the Foundation’s wiki software: volunteer software developers add new functionality to the code base, and volunteer language specialists add to the code base by translating the wiki interface into different languages. As of mid August 2016, the Foundation had approximately 452 thousand commits merged, through the efforts of approximately 2000 contributors, from which 29 thousand commits were accepted in the past 365 days, through the efforts of approximately 490 active contributors.

Event Timeline

Restricted Application added a project: Analytics. · View Herald TranscriptSep 4 2017, 2:44 PM

After a long outage (partly caused by unexpected server migration) I revived Wikistats scripts and parsed dumps in the last 10 days. So I can partially answer the question.

Yet the section on volunteers is not in Wikistats, @Aklapper would you be to able to answer that part? (I should have asked your earlier, my apologies)

Last years Quim gave the following (referring to you for this year):

"Volunteers also contribute in several ways to the Foundation’s wiki software: volunteer software developers add new functionality to the code base, and volunteer language specialists add to the code base by translating the wiki interface into different languages. As of mid August 2016, the Foundation had approximately 452 thousand commits merged, through the efforts of approximately 2000 contributors, from which 29 thousand commits were accepted in the past 365 days, through the efforts of approximately 490 active contributors."

Thanks already
Erik

As for data that Wikistats can supply: (1/2)

For the year ended June 30, 2017, volunteers added approximately 7.5 million images, movies, and sound files to the Foundation’s multimedia repository, making the total 40.6 million files.

As for data that Wikistats can supply: (2/2)

"For the year ended June 30, 2017, the educational content of the Foundation’s largest project, Wikipedia, grew by approximately 4.8 million articles to approximately 45.4 million articles total.

Yet the section on volunteers is not in Wikistats, @Aklapper would you be to able to answer that part? (I should have asked your earlier, my apologies)

Note: New system (based on Kibana and ElasticSearch) since February 2017 and hence different algorithms in the background.

Trying to exclude repositories we just fork and import from upstream FOSS projects via an explicit filter in the Advanced Search field, and trying to exclude automated changes by bots such as L10n-bot or Jenkins-mwext-sync, wikimedia.biterg.io states

(The numbers for Gerrit (not: Git) are higher due to L10n-bot activity and various other factors it seems. See T175003.)

Note that anyone could gather and play with this data. See https://www.mediawiki.org/wiki/Community_metrics#wikimedia.biterg.io for more info.

Erik_Zachte closed this task as Resolved.Sep 15 2017, 2:40 PM

Data have been relayed to Tony Sep 7.
Thanks @Aklapper for quick response.