Special:MobileHistory warning: Using deprecated fallback handling for comment rev_comment [Called from CommentStore::getCommentInternal in /Users/jrobson/git/core/includes/CommentStore.php at line 200]
Closed, ResolvedPublic

Description

When visiting Special:History I get:

Warning: Using deprecated fallback handling for comment rev_comment [Called from CommentStore::getCommentInternal in /Users/jrobson/git/core/includes/CommentStore.php at line 200] in /Users/jrobson/git/core/includes/debug/MWDebug.php on line 309

Haven't dug into this, but suspect problematic code is https://github.com/wikimedia/mediawiki-extensions-MobileFrontend/blob/master/includes/specials/SpecialMobileHistory.php#L188 (it's hard to see with the stack trace)

Logstash:
https://logstash.wikimedia.org/app/kibana#/discover?_g=h@8525ade&_a=h@4c06850
Around 20k errors every 3 hrs

Jdlrobson created this task.Sep 6 2017, 3:03 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 6 2017, 3:03 PM
Jdlrobson renamed this task from Warning: Using deprecated fallback handling for comment rev_comment [Called from CommentStore::getCommentInternal in /Users/jrobson/git/core/includes/CommentStore.php at line 200] in /Users/jrobson/git/core/includes/debug/MWDebug.php on line 309 to Special:MobileHistory warning: Using deprecated fallback handling for comment rev_comment [Called from CommentStore::getCommentInternal in /Users/jrobson/git/core/includes/CommentStore.php at line 200].Sep 6 2017, 3:03 PM
Anomie added a comment.Sep 6 2017, 3:37 PM

Backtrace is

#0 /srv/mediawiki/php-1.30.0-wmf.17/includes/debug/MWDebug.php(309): MWExceptionHandler::handleError(integer, string, string, integer, array, array)
#1 /srv/mediawiki/php-1.30.0-wmf.17/includes/debug/MWDebug.php(164): MWDebug::sendMessage(string, array, string, integer)
#2 /srv/mediawiki/php-1.30.0-wmf.17/includes/GlobalFunctions.php(1203): MWDebug::warning(string, integer, integer, string)
#3 /srv/mediawiki/php-1.30.0-wmf.17/includes/CommentStore.php(200): wfLogWarning(string)
#4 /srv/mediawiki/php-1.30.0-wmf.17/includes/CommentStore.php(334): CommentStore->getCommentInternal(Wikimedia\Rdbms\DatabaseMysqli, array, boolean)
#5 /srv/mediawiki/php-1.30.0-wmf.17/includes/Revision.php(581): CommentStore->getCommentLegacy(Wikimedia\Rdbms\DatabaseMysqli, stdClass, boolean)
#6 /srv/mediawiki/php-1.30.0-wmf.17/extensions/MobileFrontend/includes/specials/SpecialMobileHistory.php(258): Revision->__construct(stdClass)
#7 /srv/mediawiki/php-1.30.0-wmf.17/extensions/MobileFrontend/includes/specials/SpecialMobileHistory.php(134): SpecialMobileHistory->showHistory(Wikimedia\Rdbms\ResultWrapper)
#8 /srv/mediawiki/php-1.30.0-wmf.17/extensions/MobileFrontend/includes/specials/MobileSpecialPage.php(60): SpecialMobileHistory->executeWhenAvailable(string)
#9 /srv/mediawiki/php-1.30.0-wmf.17/extensions/MobileFrontend/includes/specials/MobileSpecialPageFeed.php(26): MobileSpecialPage->execute(string)
#10 /srv/mediawiki/php-1.30.0-wmf.17/includes/specialpage/SpecialPage.php(522): MobileSpecialPageFeed->execute(string)
#11 /srv/mediawiki/php-1.30.0-wmf.17/includes/specialpage/SpecialPageFactory.php(578): SpecialPage->run(string)
#12 /srv/mediawiki/php-1.30.0-wmf.17/includes/MediaWiki.php(287): SpecialPageFactory::executePath(Title, RequestContext)
#13 /srv/mediawiki/php-1.30.0-wmf.17/includes/MediaWiki.php(848): MediaWiki->performRequest()
#14 /srv/mediawiki/php-1.30.0-wmf.17/includes/MediaWiki.php(523): MediaWiki->main()
#15 /srv/mediawiki/php-1.30.0-wmf.17/index.php(43): MediaWiki->run()
#16 /srv/mediawiki/w/index.php(3): include(string)
#17 {main}

The root cause is the fact that you use * rather than Revision::selectFields() to determine the fields to select in SpecialMobileHistory::doQuery(). You should probably check anywhere else you use *, I see another stack trace via SpecialMobileContributions hitting the same warning.

Jdlrobson triaged this task as High priority.Sep 6 2017, 3:38 PM

Change 376543 had a related patch set uploaded (by Jdlrobson; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@master] Do not use deprecated fallback handling for History/Contributions

https://gerrit.wikimedia.org/r/376543

That was an easy fix..

Change 376565 had a related patch set uploaded (by Chad; owner: Jdlrobson):
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.17] Do not use deprecated fallback handling for History/Contributions

https://gerrit.wikimedia.org/r/376565

Pulling into sprint since this has been merged and is being SWATTed today (presumably due to the noise in logstash) and it's important we verify the fix.

Jdlrobson updated the task description. (Show Details)

Change 376543 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@master] Do not use deprecated fallback handling for History/Contributions

https://gerrit.wikimedia.org/r/376543

Change 376565 merged by jenkins-bot:
[mediawiki/extensions/MobileFrontend@wmf/1.30.0-wmf.17] Do not use deprecated fallback handling for History/Contributions

https://gerrit.wikimedia.org/r/376565

Mentioned in SAL (#wikimedia-operations) [2017-09-07T19:05:50Z] <demon@tin> Synchronized php-1.30.0-wmf.17/extensions/MobileFrontend/includes/specials/SpecialMobileHistory.php: T175161 (duration: 00m 49s)

demon closed this task as Resolved.Sep 7 2017, 7:10 PM
demon assigned this task to Jdlrobson.
demon added a project: Wikimedia-log-errors.