Add a 'Learners' (autoconfirmed) filter to New Pages Feed and rename the existing 'new editors' filter
Closed, ResolvedPublic

Description

Because of the ACTRIAL experiment, the current "new editor" filter on the page curation toolbar will become useless since non-autoconfirmed users will no longer be able to create pages in the article space. A new filter for autoconfirmed users will be useful for he NPP community during the time of the trial and after, and will be added.

The new, autoconfirmed filter and the old "new editors" filter work identically with the "experience level" filters defined for the New Filters for Edit Review project ("Learners" and "Newcomers," respectively). For consistency's sake, then, we will conform the filter names of the filters in New Pages Feed to match the new standard created with the New Filters project.

Changes to make

  • Add a new filter to the menu that finds changes by (registered) users who have a) 10 edits and 4 days of activity or more but b) fewer than 500 edits and 30 days of activity.
  • This filter will be named: Were created by Learners (autoconfirmed users)
  • Rename the current "new editors" filter to: Were created by Newcomers (non-autoconfirmed users)
    • Widen the menu to accommodate this name.

See screenshot below.

Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptSep 7 2017, 1:08 AM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
IVORK added a subscriber: IVORK.Sep 7 2017, 1:55 AM

I think we can get this done in the coming weeks, if it will help out.

To be clear, do you want a filter that finds changes by users who have:

  • At least 10 edits and 4 days of activity but
  • Less than 500 edits and 30 days of activity

I.e., a filter to find autoconfirmed users only?

Or are you simply looking for a filter that finds changes by everyone who has fewer than 500 edits and 30 days of activity I.e., everyone who isn't extended confirmed? Of course, during ACTRIAL, there would be no distinction, so maybe it doesn't matter. But you might as well say which one you want.

I think adding the "AC but not EC" filter next to the existing one makes the most sense. The old one can be hidden once the pages created by non-autoconfirmed users are taken care of and ACTRIAL is made permanent. The new filter will remain useful even if ACTRIAL is unsuccessful.

After reading the above, I concur with @Rentier . If ACTRIAL is made permanent we can deal with removing the old feature then. Adding a new filter will be useful for ACTRIAL both during and after regardless of the outcome.

So @jmatazzoni , to answer your question creating a filter where the users have:

  • At least 10 edits and 4 days
  • Less than 500 edits and 30 days

Seems like it would be the best way forward at this time. Thanks for your quick response to this.

After reading the above, I concur with @Rentier . If ACTRIAL is made permanent we can deal with removing the old feature then. Adding a new filter will be useful for ACTRIAL both during and after regardless of the outcome.

So @jmatazzoni , to answer your question creating a filter where the users have:

  • At least 10 edits and 4 days
  • Less than 500 edits and 30 days

    Seems like it would be the best way forward at this time. Thanks for your quick response to this.

Thanks @TonyBallioni. Sounds good. If we're adding a new filter, I suggest the following: Since the filters discussed above work identically to the "experience-level" filters defined for the New Filters for Edit Review (moving out of beta on RC page soon), we should conform their names with the New Filters names, so we have a consistent filtering experience. (Otherwise we'd have two sets of filters that do the same things but are named differently). So:

  • The existing "New users" filter becomes "Newcomers"
  • And the new filter we create will be named "Learners (autoconfirmed)"

I added the parenthetical "autoconfirmed" as a way to define this while staying consistent, as I say. You can read about the experience level filters in the New Filters documentation.

If that sounds good, I'll write it up as a spec in the Description above.

Thanks @TonyBallioni. Sounds good. If we're adding a new filter, I suggest the following: Since the filters discussed above work identically to the "experience-level" filters defined for the New Filters for Edit Review (moving out of beta on RC page soon), we should conform their names with the New Filters names, so we have a consistent filtering experience. (Otherwise we'd have two sets of filters that do the same things but are named differently). So:

  • The existing "New users" filter becomes "Newcomers"
  • And the new filter we create will be named "Learners (autoconfirmed)"

    I added the parenthetical "autoconfirmed" as a way to define this while staying consistent, as I say. You can read about the experience level filters in the New Filters documentation.

    If that sounds good, I'll write it up as a spec in the Description above.

@jmatazzoni sounds good to me. Thanks again.

jmatazzoni renamed this task from Change "new editors" filter in New Pages Feed to be non-extended confirmed to Add a "new editors" filter in New Pages Feed to be non-extended confirmed.Sep 15 2017, 6:28 PM
jmatazzoni renamed this task from Add a "new editors" filter in New Pages Feed to be non-extended confirmed to Add a 'Learners' (autoconfirmed) filter to New Pages Feed and rename the existing 'new editors' filter.Sep 15 2017, 7:10 PM
jmatazzoni triaged this task as High priority.
jmatazzoni updated the task description. (Show Details)
jmatazzoni updated the task description. (Show Details)
jmatazzoni added a subscriber: DannyH.
jmatazzoni updated the task description. (Show Details)Sep 15 2017, 7:12 PM

I've updated the spec and moved this to the Ready for Pickup column. We'll try to act on this as quickly as possible.

BTW, regarding the name changes here: Some may wonder why we didn't just name the New Filters for Edit Review filters referenced in the task description "Autoconfirmed" and "Non-autoconfirmed" instead of "Learners" and "Newcomers." The reason is that the definitions of autoconfirmed etc. vary from wiki to wiki. (Also, those terms aren't very self-explanatory for those not in the know.)

On en.Wiki only authorised users are allowed to use the New Pages Feed. It is expected that they should be in the know. They receive a monthly newsletter (and more often if the need arises)

jmatazzoni added a comment.EditedSep 21 2017, 4:48 PM

On en.Wiki only authorised users are allowed to use the New Pages Feed. It is expected that they should be in the know.

Understood. Actually, on page curation, including both terms (Learners and autoconfirmed) is probably more useful as a way of teaching NPP old hands about the new terminology they'll find on less expert systems like Recent Changes (Learners, Newcomers) than it is about making Page Curation accessible to newer users. It's just a general consistency thing.

Change 391151 had a related patch set uploaded (by Catrope; owner: Catrope):
[mediawiki/extensions/PageTriage@master] Add a filter for learners (newly autoconfirmed users)

https://gerrit.wikimedia.org/r/391151

In my patch I took the artistic liberty to clarify "learners" as "newly autoconfirmed users". Here's a screenshot of my patch in action:

Note that, once deployed, only newly created pages by learners will be picked up by the learner filter. It's not retroactive, because of the way tagging works in PageTriage.

@kaldari Could you review this patch maybe?

Change 391151 merged by jenkins-bot:
[mediawiki/extensions/PageTriage@master] Add a filter for learners (newly autoconfirmed users)

https://gerrit.wikimedia.org/r/391151

@Catrope 'Learners' filters do not return expected results. Please check the steps below - am I am missing something?

(1)
In enwiki betalabs User ET47 with user_editcount = 11 and user_registration: 20151002201829 creates a page Mavetuna47. The page is correctly displayed on RC page with Learners' filter , Page creation filters :

The page is a subject for review - Special:NewPagesFeed shows it when the filter is set to 'Unreviewed', 'Nominated for deletion', and 'Show all'. And both user_editcount = 11 and user_registration: 20151002201829 are correctly displayed:

When I apply 'Learners' filter - nothing is returned (although there were some other unreviewed pages created by Learner level users).

(2) 'Newcomers' filter works.

Re-checked for 'Learners' filter in betalabs - it works now, thx to @Catrope.
QA Recommendation: Resolve

jmatazzoni closed this task as Resolved.Dec 5 2017, 2:03 AM