Page MenuHomePhabricator

rebuildLocalisationCache demands a localisation cache
Closed, InvalidPublic

Description

MW 1.29.

hhvm -d hhvm.jit=0 maintenance/rebuildLocalisationCache.php --lang=en,ru

Fatal error: Uncaught exception 'MWException' with message 'No localisation cache found for English. Please run maintenance/rebuildLocalisationCache.php.' in /var/www/wiki/w/includes/cache/localisation/LocalisationCache.php:479

Are you kidding?

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 7 2017, 5:25 AM

--force doesn't help.

This is caused by some extensions that set up a parser function with Parser->setFunctionHook() which calls MagicWord::get().

Krinkle closed this task as Invalid.Mar 6 2019, 12:00 AM
Krinkle added a subscriber: Krinkle.

Which extension? That seems like a bug in the extension, not something we can fix from the side of the rebuildLocalisationCache.php maintenance script.