Page MenuHomePhabricator

Adjust the empty states for lists in the Translation Dashboard
Closed, ResolvedPublic

Description

When the user has no in-progress or published translation, those lists are empty in the dashboard and we show a message encouraging users to translate.

The recent adjustments made the styling of the list in those cases to be contradicting: the empty state message is frames as part of the list but the background color is used making it look like part of the background:

The following adjustments are proposed:

  • Make the background white to show the empty state message as part of the list.
  • Hide the language filters when there are no list items to be filtered.
  • Increase the padding around the empty state message (I used 40px).

An example below shows the above ideas applied:

Details

Related Gerrit Patches:
mediawiki/extensions/ContentTranslation : masterAdjust the empty states for lists in CX dashboard

Event Timeline

Suhadakashter closed this task as a duplicate of T175367: Page wikipedia.
Reedy reopened this task as Open.Sep 8 2017, 2:11 PM

Change 376736 had a related patch set uploaded (by Petar.petkovic; owner: Petar.petkovic):
[mediawiki/extensions/ContentTranslation@master] Adjust the empty states for lists in CX dashboard

https://gerrit.wikimedia.org/r/376736

Change 376736 merged by jenkins-bot:
[mediawiki/extensions/ContentTranslation@master] Adjust the empty states for lists in CX dashboard

https://gerrit.wikimedia.org/r/376736

Checked in cx-testing - all specs are in place.

Etonkovidova closed this task as Resolved.Sep 19 2017, 11:42 PM