Enable WikidataPageBanner extension on ru.wikimedia.org
Closed, ResolvedPublic

Description

There is PAGEBANNER extension used on Wikivoyage.
We would like to activate this extension on the ru.wikimedia.org (Russian Wikimedia chapter's wiki).
I'm director of Wikimedia RU, and I hope it's enough for this request.

Thank you in advance!

Drbug created this task.Sep 8 2017, 11:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 8 2017, 11:48 AM
Suhadakashter closed this task as a duplicate of T175367: Page wikipedia.
Reedy reopened this task as Open.Sep 8 2017, 2:12 PM
Legoktm renamed this task from PAGEBANNER extension activation on ru.wikiMedia.org to Enable WikidataPageBanner extension on ru.wikimedia.org.Sep 8 2017, 7:27 PM
Legoktm updated the task description. (Show Details)
Restricted Application added a project: User-MarcoAurelio. · View Herald TranscriptSep 9 2017, 1:06 PM

Change 376897 had a related patch set (by MarcoAurelio) published:
[operations/mediawiki-config@master] Enable WikidataPageBanner for Russian Wikimedia chapter wiki

https://gerrit.wikimedia.org/r/376897

MarcoAurelio triaged this task as Low priority.Sep 9 2017, 1:10 PM

Change 376897 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable WikidataPageBanner for Russian Wikimedia chapter wiki

https://gerrit.wikimedia.org/r/376897

Change 377275 had a related patch set uploaded (by MarcoAurelio; owner: MarcoAurelio):
[operations/mediawiki-config@master] Enable WikidataPageBanner for Russian Wikimedia chapter wiki

https://gerrit.wikimedia.org/r/377275

We couldn't have this patch applied today due to an incident. We'll try to have this deployed in next windows.

Change 377275 merged by jenkins-bot:
[operations/mediawiki-config@master] Enable WikidataPageBanner for Russian Wikimedia chapter wiki

https://gerrit.wikimedia.org/r/377275

Mentioned in SAL (#wikimedia-operations) [2017-09-12T13:26:40Z] <hashar@tin> Synchronized wmf-config/InitialiseSettings.php: Enable WikidataPageBanner for Russian Wikimedia chapter wiki - T175356 (duration: 00m 45s)

@Drbug I think this is done, but I cannot find any banners on pages yet.

Ctac added a subscriber: Ctac.Sep 14 2017, 10:32 AM

@Drbug I think this is done, but I cannot find any banners on pages yet.

Alas, but the extension does not work. :(

Check it out for yourself. Add string {{PAGEBANNER:Moscow Banner.jpg|toc=yes|pgname=Some page}} to any page of ru.wikiMedia.org and press Preview. And then try to do the same in Wikivoyage.

We need this extension for the pages of events and competitions held by Wikimedia Russia. For example: https://ru.wikimedia.org/wiki/WK17EN

@Ctac I did as you mentioned on [[Example]], hit preview and I see the banner.

Ctac added a comment.Sep 14 2017, 10:55 AM

Thank you! It began to work. It's possible that I did not wait for the big picture to load.

MarcoAurelio closed this task as Resolved.Sep 14 2017, 11:05 AM
MarcoAurelio moved this task from ready to archive on the User-MarcoAurelio board.

@Ctac I'm glad it's working for you too. I'll close this task as resolved, then. If there are any new issues, please reopen this task. Regards.