Page MenuHomePhabricator

special:import imports duplicate revisions from the Nostalgia Wikipedia
Open, Needs TriagePublic

Description

Previously, when deciding which revisions to import, Special:Import ignored any revisions in the source wiki/file that had exactly the same timestamp and username, but slightly different text. This was handy for the Nostalgia Wikipedia, a read-only copy of the English Wikipedia database from 20 December 2001 that, for various reasons, has slightly different text to the current Wikipedia database. Now Special:Import imports them anyway; this happened at the Fernando Pessoa and Abdul Hamid II articles on the English Wikipedia. The system was working fine yesterday, when I imported an edit from the Nostalgia Wikipedia to User:User:Sjn28.

Related Objects

Event Timeline

Graham87 created this task.Sep 8 2017, 11:52 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 8 2017, 11:52 AM

Thanks for reporting this.
Can you please provide a link to the specific issue?

Thanks for reporting this.
Can you please provide a link to the specific issue?

Sure. Here's a permalink to the logs of the two bad imports:
https://en.wikipedia.org/w/index.php?title=Special:Log&dir=prev&offset=20170907095311&limit=2&type=import&user=Graham87&page=&tagfilter=&hide_thanks_log=1&hide_patrol_log=1&hide_tag_log=1&hide_review_log=1

In both cases, Special:Import should've only imported one revision. This is how it worked until today (UTC).

Suhadakashter closed this task as a duplicate of T175367: Page wikipedia.
TTO reopened this task as Open.Sep 8 2017, 2:08 PM
Reedy added a subscriber: Reedy.Sep 8 2017, 2:22 PM

The only change I can see to Import code is https://gerrit.wikimedia.org/r/#/c/357892/

But that would've been there in last weeks branch?