Page MenuHomePhabricator

[Bug] Particular wikibase-…-summary-…-update autocomments are missing in en.json
Closed, ResolvedPublic

Description

See this edit. It was made by wbremoveclaims call with multiple claim='s. Tested in English, Czech and qqx.

Details

Related Gerrit Patches:
mediawiki/extensions/Wikibase : masterAdd missing messages for Wikibase autocomments

Event Timeline

Restricted Application added a project: Wikidata. · View Herald TranscriptSep 10 2017, 5:00 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
thiemowmde triaged this task as Medium priority.Oct 23 2017, 6:43 AM
thiemowmde moved this task from incoming to ready to go on the Wikidata board.

https://www.wikidata.org/w/index.php?title=Q32069506&diff=prev&oldid=555640928:

  • The bogus output: wbremoveclaims-update:0|: removing redundant property
  • With uselang=qqx: wikibase-item-summary-wbremoveclaims-update: 0,

https://www.wikidata.org/w/index.php?title=Q233693&curid=227349&diff=581916164&oldid=578532193:

  • The bogus output: ‎wbsetaliases-update:2|es: Elizabeth "Betty" Short, Black Dahlia
  • With uselang=qqx: wikibase-item-summary-wbsetaliases-update: 2, es

The reason for both is super trivial: these messages are just missing in lib/i18n/en.json!

Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptOct 23 2017, 6:43 AM
thiemowmde renamed this task from Particular autocomment doesn't get expanded to [Bug] Particular wikibase-…-summary-…-update autocomments are missing in en.json.Oct 23 2017, 6:44 AM

Why does "-item-" comment get preferred over "-entity-", which does exist, when it doesn't exist?

Thanks for bringing this up. The idea is that …-entity-… works as a fallback when …-item-… does not exist. In the cases we are discussing here both don't exist. We should add the missing …-entity-… messages.

There seems to be Regression: for the first change, I would expect wikibase-entity-summary-wbremoveclaims-remove instead.

Change 407408 had a related patch set uploaded (by Matěj Suchánek; owner: Matěj Suchánek):
[mediawiki/extensions/Wikibase@master] Add missing messages for Wikibase autocomments

https://gerrit.wikimedia.org/r/407408

thiemowmde closed this task as Resolved.Feb 2 2018, 1:04 PM
thiemowmde claimed this task.
thiemowmde edited projects, added Wikidata-Sprint-2018-01-31; removed Patch-For-Review.
thiemowmde moved this task from Backlog to Done on the Wikidata-Sprint-2018-01-31 board.

Change 407408 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Add missing messages for Wikibase autocomments

https://gerrit.wikimedia.org/r/407408