Page MenuHomePhabricator

jQuery.fx.interval on nlwiki Special:Search
Closed, DeclinedPublic

Description

JQMIGRATE: jQuery.fx.interval is deprecated on https://nl.wikipedia.org/wiki/Special:Search

Does not seem to appear on every page load, or happens with a delay, or some other condition.

Can't find any page in the MediaWiki namespace containing "interval", so probably imported.

Related Objects

StatusSubtypeAssignedTask
ResolvedKrinkle
DeclinedNone

Event Timeline

Nirmos created this task.Sep 11 2017, 1:59 AM
Restricted Application added projects: Discovery, Discovery-Search. · View Herald TranscriptSep 12 2017, 9:03 AM
debt added a subscriber: debt.

We'd have to take a look at this (might be custom code on nlwiki)...if it's only deprecated and not removed, that might be ok.

In a quick test I'm not able to reproduce. Can you use the debug=1 query parameter to see what javascript this comes from?

This seems to come from jQuery itself. Line 3847, column 55:

function schedule() {
    if (inProgress) {
        if (document.hidden === false && window.requestAnimationFrame) {
            window.requestAnimationFrame(schedule);
        } else {
            window.setTimeout(schedule, jQuery.fx.interval);
        }
        jQuery.fx.tick();
    }
}

migrateWarn @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:10346
get @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:10357
schedule @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:6780
jQuery.fx.start @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:7428
jQuery.fx.timer @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:7418
Animation @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:7152
doAnimation @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:7262
dequeue @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:4401
(anonymous) @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:4443
each @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:362
each @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:157
queue @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:4436
animate @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:7273
(anonymous) @ jquery.ime.js?b8aa2:948
setTimeout (async)
resetTimer @ jquery.ime.js?b8aa2:946
focus @ jquery.ime.js?b8aa2:966
position @ jquery.ime.js?b8aa2:1151
disableIM @ jquery.ime.js?b8aa2:1357
selectIM @ jquery.ime.js?b8aa2:1327
selectLanguage @ jquery.ime.js?b8aa2:1262
mw.ime.addIme @ ext.uls.ime.js?72e70:318
mw.ime.handleFocus @ ext.uls.ime.js?72e70:268
(anonymous) @ ext.uls.interface.js?b7e30:499
fire @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3317
fireWith @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3447
deferred.(anonymous function) @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3778
(anonymous) @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:12900
handlePending @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:11942
markModuleReady @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:12183
nestedAddScript @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:12190
(anonymous) @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:12195
fire @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3317
fireWith @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3447
deferred.(anonymous function) @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3778
(anonymous) @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:12120
fire @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3317
fireWith @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:3447
done @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:9272
callback @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:9639
dispatch @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:5206
elemData.handle @ load.php?debug=true&lang=sv&modules=jquery%2Cmediawiki|mediawiki.legacy.wikibits&only=scripts&skin=vector&version=1b6aucj:5014

EBernhardson closed this task as Declined.Sep 25 2017, 10:00 PM

Poked around a little, this looks like a false positive. jQuery 3 itself is using the deprecated property so there is nothing for us to do. The fix will have to be when upstream stops using the deprecated property.

Has this been reported to upstream yet?