Exception when unbulleting the final bullet of a list
Closed, ResolvedPublic1 Story Points

Description

Steps to reproduce:

  • In VE standalone, edit <ul><li>X</li><li>Y</li></ul> .
  • Put the cursor just after Y (on the same line), and use the toolbar to turn off the bulleting

Observed behaviour: ve.ce.ContentBranchNode#onTeardown throws an exception because this.root is null.

Expected behaviour: The unbulleting works without an exception.

The TreeModifier change would naturally be the prime suspect, and indeed the broken behaviour was introduced by 37d1512a74bd51038fd837656beb065aa0564d7e .

dchan created this task.Sep 11 2017, 11:48 AM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 11 2017, 11:48 AM

Should we be reverting TreeModifier again before release then? @Deskana @Jdforrester-WMF

Should we be reverting TreeModifier again before release then? @Deskana @Jdforrester-WMF

We probably need to. It seems unlikely we can diagnose and fix the issue before then.

Change 377510 had a related patch set uploaded (by Divec; owner: Divec):
[VisualEditor/VisualEditor@master] ve.ce.BranchNode#splice: disconnect nodes fully

https://gerrit.wikimedia.org/r/377510

dchan added a comment.Sep 12 2017, 5:07 PM

It looks like we were leaving zombie connections to nodes long ago torn down, which then reacted badly to TreeModifier causing methods to be called on their non-existent root.

Change 377510 merged by jenkins-bot:
[VisualEditor/VisualEditor@master] ve.ce.BranchNode#splice: disconnect nodes fully

https://gerrit.wikimedia.org/r/377510

Change 377524 had a related patch set uploaded (by Jforrester; owner: Jforrester):
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (dafc7bbe5)

https://gerrit.wikimedia.org/r/377524

Change 377524 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] Update VE core submodule to master (dafc7bbe5)

https://gerrit.wikimedia.org/r/377524

Deskana set the point value for this task to 1.Sep 12 2017, 6:36 PM
Deskana closed this task as Resolved.

Why revert when you can just fix it? :-)

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 12 2017, 6:36 PM