Page MenuHomePhabricator

Checkuser on IP ranges produces no results, even if there are edits in that range
Closed, ResolvedPublic

Description

Reported in checkuser-l I think it's related to deploy of wmf.18 and thus should be a blocker of the train

Specifically, the bug is that IP range checks do not give results even if IPs in that range have edits. For example, a check on 37.228.251.79 correctly shows edits, so a check on 37.228.251.0/24 should show at a minimum those edits from 37.228.251.79, but it (incorrectly) does not show any results at all.

Event Timeline

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 14 2017, 9:13 AM
Ladsgroup triaged this task as Unbreak Now! priority.Sep 14 2017, 9:14 AM
Restricted Application added subscribers: Liuxinyu970226, Jay8g, TerraCodes. · View Herald TranscriptSep 14 2017, 9:14 AM
Samtar added a subscriber: Samtar.Sep 14 2017, 9:16 AM
Deskana renamed this task from Checkuser on IPs is not working to Checkuser on IP ranges produces no results, even if there are edits in that rage.Sep 14 2017, 9:29 AM
Deskana renamed this task from Checkuser on IP ranges produces no results, even if there are edits in that rage to Checkuser on IP ranges produces no results, even if there are edits in that range.
Deskana updated the task description. (Show Details)
Deskana updated the task description. (Show Details)
DoRD added a subscriber: DoRD.Sep 14 2017, 9:43 AM
MarcoAurelio added a subscriber: MarcoAurelio.
Melos added a subscriber: Melos.Sep 14 2017, 10:00 AM
Stryn added a subscriber: Stryn.Sep 14 2017, 10:52 AM

Change 378022 had a related patch set uploaded (by Melos; owner: Melos):
[mediawiki/extensions/CheckUser@master] Fix Special cu for ip ranges (temp)

https://gerrit.wikimedia.org/r/378022

Change 378022 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@master] Fix Special cu for ip ranges (temp)

https://gerrit.wikimedia.org/r/378022

Change 378025 had a related patch set uploaded (by Melos; owner: Melos):
[mediawiki/extensions/CheckUser@wmf/1.30.0-wmf.18] Fix Special cu for ip ranges (temp)

https://gerrit.wikimedia.org/r/378025

Huji added a subscriber: Huji.Sep 14 2017, 1:37 PM

@Melos where did that line drop from the code base? For regressions like this, it is always best to find out how they occurred, and mention the patch ID in the commit message.

Huji added a comment.Sep 14 2017, 1:39 PM

It turns out it was actually my own doing in c74d13b37a47; dang it!

Huji closed this task as Resolved.Sep 14 2017, 1:48 PM
Huji claimed this task.

Yeah, between me, MusikAnimal and the unit test, we all failed to notice that. :(

Change 378025 merged by jenkins-bot:
[mediawiki/extensions/CheckUser@wmf/1.30.0-wmf.18] Fix Special cu for ip ranges (temp)

https://gerrit.wikimedia.org/r/378025

Adding a regression test would be really appreciated.

You have to admit the irony, though... before only CUs could see contribs in an IP range, this week ALL users get to (T163562), but it broke for CUs!!! OK not that funny. Sorry :(

Yeah, between me, MusikAnimal and the unit test, we all failed to notice that. :(

I was thinking this function (and others) seem easily unit testable. There aren't any tests right now, though? I'm going to write some :)

Mentioned in SAL (#wikimedia-operations) [2017-09-14T14:07:14Z] <dereckson@tin> Synchronized php-1.30.0-wmf.18/extensions/CheckUser/specials/SpecialCheckUser.php: Fix Special cu for ip ranges (temp) (T175898) (duration: 00m 49s)

Huji added a comment.Sep 14 2017, 3:01 PM

You have to admit the irony, though...

Hilarious!

I was thinking this function (and others) seem easily unit testable. There aren't any tests right now, though? I'm going to write some :)

Please join T175920!

MarcoAurelio moved this task from Backlog to Closed on the CheckUser board.Nov 22 2017, 9:42 AM