Page MenuHomePhabricator

CodeMirror on NWE: pasting problems from one surface to another - line size?
Closed, ResolvedPublic

Description

Try to copy https://en.wikipedia.beta.wmflabs.org/wiki/CodeMirror/src?veaction=editsource to https://en.wikipedia.beta.wmflabs.org/wiki/CodeMirror?veaction=editsource (for example to beginning of text). Then try to change something after. Changes are not visible on clicked (with caret) line! Tried on Firefox but try to zoom* page if you can not reproduce.

  • - I think the cause is synchronization with line heights.

Event Timeline

Wargo created this task.Sep 14 2017, 8:38 PM
Restricted Application added a project: VisualEditor. · View Herald TranscriptSep 14 2017, 8:38 PM
Restricted Application added a subscriber: Aklapper. · View Herald Transcript
Restricted Application added a project: Community-Tech. · View Herald TranscriptNov 7 2017, 11:26 PM
Niharika triaged this task as Low priority.Nov 7 2017, 11:59 PM
TheDJ closed this task as Resolved.Jun 17 2018, 9:03 PM
TheDJ claimed this task.
TheDJ added a subscriber: TheDJ.

i'm pretty sure this was fixe a while ago.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptJun 17 2018, 9:03 PM