Page MenuHomePhabricator

Outreachy - webservice microtask for Mridu_Bhatnagar
Closed, ResolvedPublic

Description

  • Register for Developer access
  • Read the Gerrit tutorial
  • Clone the project repository from Gerrit
  • Read over the source code and try to understand what scripts/webservice does when a user runs it as:
  • webservice --backend kubernetes start
  • webservice --backend kubernetes stop
  • Submit a patch to Gerrit adding a "Outreachy-task.<your shell username>.txt" file that describes your understanding of the webservice --backend kubernetes {start,stop} commands from the previous step.
  • Add BryanDavis, Madhuvishy, and Andrew Bogott as reviewers for your new Gerrit patch.

Event Timeline

@Mridu_Bhatnagar Hello! just checking, how is your progress on the microtask going? Stuck somewhere, or have questions, then do not hesitate to ask :)

@srishakatux Hello! Was relocating hence, wasn't able to continue since a couple of days. From today going to start again. :)
Thanks.

@Mridu_Bhatnagar no worries, I was just checking! :)

Hi,
@bd808,
@madhuvishy,
@Andrew,
@srishakatux,

I have completed the microtask assigned as a part of outreachy round 15 project . Improvement in the toolforge webservice application.

Thanks
Mridu

Change 381296 had a related patch set uploaded (by Mridubhatnagar; owner: Mridubhatnagar):
[operations/software/tools-webservice@master] Explain scripts/webservice does

https://gerrit.wikimedia.org/r/381296

Change 381296 had a related patch set uploaded (by Mridubhatnagar; owner: Mridubhatnagar):
[operations/software/tools-webservice@master] Explain scripts/webservice

https://gerrit.wikimedia.org/r/381296

bd808 closed this task as Resolved.Oct 4 2017, 7:39 PM

@Mridu_Bhatnagar Your gerrit patch looks good. I think we can call this microtask done. Your next step is to write up a project proposal based on the list of issues that are outlined in the parent task. Try to think roughly about how difficult each one seems to be to you and how important fixing the issue is likely to be. Describe in your proposal which issues you think you can address and how they will fit together to make using the script as a Toolforge developer a better experience.

@Mridu_Bhatnagar Just making sure.. that you've checked whether or not you meet the eligibility criteria listed here https://www.outreachy.org/apply/eligibility/

When you start working on the application on the Outreachy program website, fill out the eligibility information first, even if you don't know yet what content should go in other parts of the application. That will allow Outreachy organizers to verify (see point 3 under "How to Apply" section https://www.outreachy.org/apply/).

Lastly, make sure you have read point number 9 under "Application Process Steps" here https://www.mediawiki.org/wiki/Outreachy/Participants

If you have any questions about the application process, please ask!

@Mridu_Bhatnagar Your gerrit patch looks good. I think we can call this microtask done. Your next step is to write up a project proposal based on the list of issues that are outlined in the parent task. Try to think roughly about how difficult each one seems to be to you and how important fixing the issue is likely to be. Describe in your proposal which issues you think you can address and how they will fit together to make using the script as a Toolforge developer a better experience.

Thank you @bd808 :). Yes would start off with it.

@Mridu_Bhatnagar Just making sure.. that you've checked whether or not you meet the eligibility criteria listed here https://www.outreachy.org/apply/eligibility/

When you start working on the application on the Outreachy program website, fill out the eligibility information first, even if you don't know yet what content should go in other parts of the application. That will allow Outreachy organizers to verify (see point 3 under "How to Apply" section https://www.outreachy.org/apply/).

Lastly, make sure you have read point number 9 under "Application Process Steps" here https://www.mediawiki.org/wiki/Outreachy/Participants

If you have any questions about the application process, please ask!

Thanks for the token and help @srishakatux. Would need all of yours help for the application process. Doing something of this sought for the very first time.

Change 381296 abandoned by BryanDavis:
Explain scripts/webservice

Reason:
Marking as abandoned so that we don't accidentally merge this. The patch was accepted for the purposes of the Outreachy microtask.

https://gerrit.wikimedia.org/r/381296